Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm using SelfSSL7 to create a self signed certificate in IIS 7.5(Win Server 2K8 R2). I have 2 sites in IIS ( the default site and a test site). I ran the following to create the cert.

SelfSSL7.exe /Q /T /I "Default Web Site" /N cn=MyMachineName;cn=localhost /K 1024 /V 18250 SelfSSL7.exe /Q /T /I /S "TestSite" /N cn=myhostheader;cn=myhostheader.mydomain.com /K 1024 /V 18250 appcmd.exe set site /site.name:TestSite /bindings.[protocol='https',bindingInformation=':443:'].bindingInformation::443:myhostheader

This works but the https 443 binding for the "Default Site" ends up using the same certificate as the test site so I'm unable to use SSL for both sites on port 443. This article explains the issue but I can't seem to find a workaround. I would like to use a different self signed certs for SSL per website. How can I achieve this?

share|improve this question

1 Answer 1

This is not possible.

The TechNet forum post you linked involves trying to set up multiple sites on the same wildcard certificate on the same port, which is definitely possible.

However, using two distinct, different certificates on the same port as you are attempting falls into the realm of requiring TLS Server Name Indication. No current version of IIS supports this.

share|improve this answer
    
What are my options? Should I generate just one certificate with the CN set to "*.domainname.com"(if this is possible) and use that for all web sites? –  Abhijeet Patel May 22 '11 at 5:59
    
Yes, that would work. –  Shane Madden May 22 '11 at 6:16
    
Would the URLs for the sites need to be domain qualified. i.e if my host header is "mytestapp" then would the URL need to be mytestapp.mydomain.com. That is just mytestapp would not work? –  Abhijeet Patel May 22 '11 at 6:59
    
Wilcarding the CN does not work:I tried this: SelfSSL7 /Q /T /I "Default WebSite" /N cn=" *.mydomain.com";cn=mymachinename;cn=localhost /K 1024 /V 18250 This is the error I get:Common name (/N cn= *.mydomain.com) contains invalid characters. –  Abhijeet Patel May 22 '11 at 17:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.