Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We have a network share on a server, call it foo. When trying to enter \\foo\C$ in Windows explorer address bar, I get an error that the resource cannot be found. However, when I append the domain name, e.g., \\foo.ene.com\C$ the right thing occurs.

The domain name searches are properly set in the network connection settings and pinging the server resolves correctly. I'm friggin baffled.

Any ideas?

share|improve this question
    
Is this in a domain environment and are both machines members in the same domain? –  squillman Jun 17 '09 at 14:05
    
That is indeed strange. –  MathewC Jun 17 '09 at 14:12

3 Answers 3

up vote 2 down vote accepted

So here's what I did that ended up fixing the problem, although I don't know why.

ipconfig /flushdns --no joy
give up the DHCP lease and get a new one --nada
reboot --zip
resetting the tcp/ip stack --FIXED

Any theories as to what happened here?

share|improve this answer
    
It may have re-registered your name with WINS. –  crb Jun 17 '09 at 14:45
    
GAHH I have this problem EVERY SINGLE DAY with Windows Vista on my wifi network at home. At work it's fine, but every single damn time I go home in the evening I have to reset the TCP/IP stack! –  Mark Henderson Jun 18 '09 at 3:37
    
How do you reset the tcp/ip stack?</noob> –  Jürgen A. Erhard Jan 10 '10 at 16:34

Are you running WINS? A short name can be looked up with WINS, where a long name will force DNS.

share|improve this answer

It looks like yoour computer doesnt know on which dns domain it have to search for the server foo. Normaly the dns domain should be given by the dhcp server or the active directory (I'm not sure about that in windows domains).

I'm assuming you're using Windows XP. Try to add the dns domain by hand: Open the Network Connection Propoerties of your LAN Adapter under start -> settings -> network connections. Mark "Internet protocol TCP/IP" and click on the button "Settings".

In the next dialog open "Advanced" under the Tab "DNS" mark the Option Append this DNS suffixes (in order)" and add the dns domain ene.com and apply the changes.

The windows share should be accessible over \foo\c$ now.

share|improve this answer
    
Sorry. Sometimes the question should be read exactly ;-) Maybe a "ipconfig /flushdns" executed from command line helps. What does the command "nslookup foo" respond? –  grub Jun 17 '09 at 14:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.