Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

My question is;I can't connect to network 192.168.1.0 .Where I wrong? Here is my cisco command.Also, no output from 'show ip route' command.

Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#no ip route 192.168.1.0 255.255.255.0 192.168.1.2 
Router(config)#wr

Router#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
   D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
   N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
   E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
   i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
   * - candidate default, U - per-user static route, o - ODR
   P - periodic downloaded static route

 Gateway of last resort is not set

 172.168.0.0/24 is subnetted, 1 subnets
C       172.168.1.0 is directly connected, Serial0/1/0
C    192.168.2.0/24 is directly connected, FastEthernet0/0
Router#sh run
Building configuration...

Current configuration : 627 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
! 
hostname Router
!
!
!
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
!
!
!
!
interface FastEthernet0/0
ip  address 192.168.2.254 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
! 
interface Serial0/1/0
 ip address 172.168.1.2 255.255.255.0
 ipv6 ospf cost 781
 !
interface Vlan1
 no ip address
 shutdown
 !
 ip classless
 ip route 192.168.1.0 255.255.255.0 172.16.1.1 
 !
 !
 !
 no cdp run
 ! 
 !
 !
 !
 !
 line con 0
 line    vty 0 4
 login
 !
 !
 !
 end
share|improve this question
    
Has the 192.168.1.0 vlan got a route back to 172.168.1.0/24 and 192.168.2.0/24? If you don't have any output from sh ip route none of the interfaces are up, what does sh int show? –  HampusLi May 23 '11 at 11:54
    
Could you elaborate on the conditions of the problem? I'm sorry but this question is pretty bad right now. –  Mike Pennington May 23 '11 at 12:16

4 Answers 4

Assuming you want to send the traffic over Serial0/1/0 you will need to double check that you entered the correct IP addresses. Serial0/1/0 has 172.168.1.2 where the route has 172.16.1.1.

share|improve this answer

You are pointing to an ip address that is not present in you routing table. Of course it will not work. I think this should be like this : ip route 192.168.1.0 255.255.255.0 Serial 0/1/0

share|improve this answer

It is probably a typo: You are so used to typing 192.168.x.x that when you go to type 172.16.x.x, you actually typed 172.168.x.x, adding the "8".

share|improve this answer

Like xciter said, there's no 192.168.1.0 interface on the router. Did you mean to have

  • ip route 192.168.1.0 255.255.255.0 172.16.1.1
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.