Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

The "sharing and security" option in the right-click context menu on a folder is no longer there. The File and Print sharing option is "installed" and turned on in the TCP/IP properties, but the ability to share any folders has disappeared, along with all previously shared folders. Where should I check to see what the issue is here?

EDIT From comments below:

"Server" service is not starting, see comment below for more... Firewall is completely disabled, too.

This is XP Pro, Simple File Sharing is turned on. We've discovered that the "Server" Windows service is not starting on bootup for some reason. When attempting manual start, we get "error 2001: specified driver is invalid."

share|improve this question

7 Answers 7

If this is Windows XP Home, you won't be able to see that context menu without some registry hacking. If this is Windows XP Professional, you might need to disable Simple File Sharing. In a Windows Explorer windows, go to Tools --> Folder Options. Click on the "View" tab and scroll all the way down. Uncheck the box that says "Use simple file sharing."

share|improve this answer
up vote 2 down vote accepted

We've got it solved. I found information claiming that this was related to a missing or corrupt "srv.sys" driver in c:\windows\system32\drivers. When I looked there on the fouled up machine, that file was completely missing. I copied the file from another working XP Pro machine, rebooted the problem machine, and sharing works once again. Thanks for the help, folks!

share|improve this answer
    
Hey, good deal. Thanks for posting the follow-up! –  squillman Jun 17 '09 at 15:14

In windows explorer : Alt + T ( Tools menu ) - View - last option in the list is "Use simple file sharing" Uncheck that option and Sharing and Security will be shown.

Oh, and yes, as rawarren said, if you have Windows XP home edition sharing and security is not an option :)

share|improve this answer

Is the drive you're trying to share formatted as NTFS?

Do you have simple file sharing turned on? In Windows Explorer, Pick "Folder Options" from the Tools menu, click the View tab and look for "Use simple file sharing" in the Advanced Settings list. Turn it off if it's selected.

If you have XP Home, you won't see this option in the list, you'll have to edit the registry. In Regedit, look for the key

HKEY_CURRENT_USER\Software\Microsoft\windows\CurrentVersion\Policies\Explorer

Delete the key nNamed Nosecuritytab or change the value to 0.

Check that the Computer Browser service is running, if it's not, check the services it's dependent on (Server and Workstation - see Dependencies tab). If the services won't start, I'd start to wonder if there's a corrupt file. Run the System File Checker:

Sfc /Scannow

You may need the install CD, or sfc will look in %Systemroot%\System32\Dllcache

share|improve this answer
    
This is XP Pro, Simple File Sharing is turned on. We've discovered that the "Server" Windows service is not starting on bootup for some reason. When attempting manual start, we get "error 2001: specified driver is invalid." –  colemanm Jun 17 '09 at 14:33
    
What about the Computer Browser service? If the server service isn't running, it shouldn't be either, but what's in the error log when you try to start that one? –  Ward Jun 17 '09 at 14:41

Assuming WinXP Pro:

Solution 1: open Windows Explorer and choose Folder Options from the Tools menu, then under Advanced Settings uncheck "Use simple file sharing"

Solution 2: In the registry, change HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\ForceGuest to 0

share|improve this answer

Who cares about Windows XP file sharing. I would recommend just using HFS File server. Its way easier.

share|improve this answer
    
If you're not going to bother even attempting to answer the OP's question, then don't bother to post at all. –  EEAA Apr 7 '10 at 18:50

Better Fix

click Start button click Control panel click administrative Tools click services short cut slide down to Server right click properties set start up type to automatic

done finished

share|improve this answer
    
The question states that the Server service isn't starting, so setting it to Automatic wouldn't help. –  fission Dec 8 '12 at 19:30

protected by Chris S Jan 6 at 5:34

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.