Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Virtuozzo VPS running Plesk 8.x on CentOS 4.4 and I'd like to install that latest PHP 5.3 release on it. Ideally I'd like to run 4 and 5 side by side, but I'll settle for only running 5 if I have to.

(Note that Plesk runs two instances of Apache/PHP -- one for the control panel and another to serve the client sites -- and I'm looking to upgrade the client instance, not the control panel instance)

I've downloaded the required RPMs from http://www6.atomicorp.com/channels/atomic/centos/4/i386/RPMS/, but when I try to install them I get this error:

[root@hq phprpm]# rpm -i *.rpm
warning: php-5.3.6-3.el4.art.i386.rpm: V3 DSA signature: NOKEY, key ID 5ebd2744
        file /etc/php.ini from install of php-common-5.3.6-3.el4.art conflicts with file from package php-4.3.9-3.18.1.swsoft
        file /usr/bin/php from install of php-cli-5.3.6-3.el4.art conflicts with file from package php-4.3.9-3.18.1.swsoft
        file /usr/bin/phpize from install of php-cli-5.3.6-3.el4.art conflicts with file from package php-devel-4.3.9-3.18.1.swsoft
        file /etc/httpd/conf.d/php.conf from install of php-5.3.6-3.el4.art conflicts with file from package php-4.3.9-3.18.1.swsoft
        file /var/www/icons/php.gif from install of php-5.3.6-3.el4.art conflicts with file from package php-4.3.9-3.18.1.swsoft

How can I install the PHP5 files at a separate location from the PHP4 ones? What kind of settings will I need to tweak because it's not in the default location?

If I try to upgrade PHP4 instead of installing PHP5 alongside it, I get this error:

[root@hq phprpm]# rpm -Uvh php-*.rpm
warning: php-5.3.6-3.el4.art.i386.rpm: V3 DSA signature: NOKEY, key ID 5ebd2744
error: Failed dependencies:
        php = 4.3.9-3.18.1.swsoft is needed by (installed) php-domxml-4.3.9-3.18.1.swsoft.i386
        php = 4.3.9-3.18.1.swsoft is needed by (installed) php-gd-4.3.9-3.18.1.swsoft.i386
        php = 4.3.9-3.18.1.swsoft is needed by (installed) php-imap-4.3.9-3.18.1.swsoft.i386
        php = 4.3.9-3.18.1.swsoft is needed by (installed) php-mbstring-4.3.9-3.18.1.swsoft.i386
        php = 4.3.9-3.18.1.swsoft is needed by (installed) php-mysql-4.3.9-3.18.1.swsoft.i386
        php = 4.3.9-3.18.1.swsoft is needed by (installed) php-pear-4.3.9-3.18.1.swsoft.i386
        php = 4.3.9-3.18.1.swsoft is needed by (installed) php-devel-4.3.9-3.18.1.swsoft.i386
        php = 4.3.9-3.18.1.swsoft is needed by (installed) php-ldap-4.3.9-3.18.1.swsoft.i386
        php = 4.3.9-3.18.1.swsoft is needed by (installed) php-odbc-4.3.9-3.18.1.swsoft.i386
        php = 4.3.9-3.18.1.swsoft is needed by (installed) php-pgsql-4.3.9-3.18.1.swsoft.i386
        php = 4.3.9-3.18.1.swsoft is needed by (installed) php-snmp-4.3.9-3.18.1.swsoft.i386
        php = 4.3.9-3.18.1.swsoft is needed by (installed) php-xmlrpc-4.3.9-3.18.1.swsoft.i386

It's failing because Plesk rolls their own version of PHP. I tried to workaround that with RPM --nodeps, but got this error:

[root@hq phprpm]# rpm -Uvh php*.rpm --nodeps
warning: php-5.3.6-3.el4.art.i386.rpm: V3 DSA signature: NOKEY, key ID 5ebd2744
Preparing...                ########################################### [100%]
        file /usr/bin/phpize from install of php-cli-5.3.6-3.el4.art conflicts with file from package php-devel-4.3.9-3.18.1.swsoft

If I try to uninstall php4 so I can install 5, I get this error:

[root@hq phprpm]# rpm -e --test php-4.3.9-3.18.1.swsoft php-gd-4.3.9-3.18.1.swsoft php-mbstring-4.3.9-3.18.1.swsoft php-devel-4.3.9-3.18.1.swsoft php-ncurses-4.3.9-3.18.1.swsoft php-pgsql-4.3.9-3.18.1.swsoft php-xmlrpc-4.3.9-3.18.1.swsoft php-domxml-4.3.9-3.18.1.swsoft php-imap-4.3.9-3.18.1.swsoft php-mysql-4.3.9-3.18.1.swsoft php-pear-4.3.9-3.18.1.swsoft php-ldap-4.3.9-3.18.1.swsoft php-odbc-4.3.9-3.18.1.swsoft php-snmp-4.3.9-3.18.1.swsoft
error: Failed dependencies:
        php is needed by (installed) psa-prevztune-8.1.0-17.swsoft.81563.noarch
        php >= 4.2 is needed by (installed) ZendOptimizer-3.0.1-1.swsoft.i386
        php is needed by (installed) psa-php4-configurator-1.4.0-cos4.build86080722.02.noarch
        /usr/bin/php is needed by (installed) psa-horde-3.1.7-cos4.build86080722.02.noarch
        php-gd is needed by (installed) psa-php4-configurator-1.4.0-cos4.build86080722.02.noarch
        php-mbstring is needed by (installed) psa-php4-configurator-1.4.0-cos4.build86080722.02.noarch
        php-domxml is needed by (installed) psa-php4-configurator-1.4.0-cos4.build86080722.02.noarch
        php-imap is needed by (installed) psa-php4-configurator-1.4.0-cos4.build86080722.02.noarch
        php-mysql is needed by (installed) psa-php4-configurator-1.4.0-cos4.build86080722.02.noarch

Please keep in mind that Virtuozzo VPS's don't have yum installed by default -- and I've heard it's a pain in the ass to get it working -- so I'd like to do everything via RPM.

I've checked the related questions on Server Fault, but they didn't address this specific error, and I didn't find anything on Google that was helpful.

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

I ended up just removing the old PHP packages with rpm -e --nodeps, and then installing the new ones with rpm -ivh --nodeps, and that worked.

share|improve this answer
    
That ended up break Plesk, though, so now I'm trying to find a solution to that -- serverfault.com/questions/273361/… –  Ian Dunn May 25 '11 at 16:01
add comment

Just install it through yum. "yum search php" their should be a php5 option or install a repo that has it.

share|improve this answer
1  
That'd work for a regular CentOS installation, but Virtuozzo/Plesk introduces some complexities. –  Ian Dunn Jun 29 '11 at 6:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.