Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a http sever provide service to internet, so I configured port forward in router. It’s fine for users access server outside company (URL: _ But if the user is inside company, use above url to access the server is not work. The only way to access server is use inner ip like _http://

network map picture:

I use wireshark captured tcp packets when I telnet 80,the result is can’t connect to server.

wireshark captured packet picture:

In wireshark captured packets, No 2-3 show the domain name resolution is success. No 4 my computer( access server using server outer ip( No 7 show the port foward is ok, the reply ip is server inner ip( No 8 the connection is reset (TCP Flag RST) .

Anybody know what’s the reason?

share|improve this question

migrated from May 24 '11 at 11:35

This question came from our site for professional and enthusiast programmers.

Your port forwarding is most probably only listening for requests on the public interface (internet side). Depending on the brand of your router you can configure to listen to both sides.

So we'll need more info the help you any further.

share|improve this answer
Thank your. Maybe this method is work but my router not provide choice to configure listenting interface. – powerpanda May 25 '11 at 0:28

The usual solution to this problem is to use split-dns. You need to configure your DNS server to return different IP address for your server name depending on where the query comes from. How you do this will depend on what DNS server you use, but it is a common setup.

So on the inside of your network: ->

But for outside queries: ->

share|improve this answer
The data is forward to different intranet server depending on listening port, so single ip solution is not fix it. One work round is modify c:\WINDOWS\system32\drivers\etc\hosts on users computer and give domain name solution. – powerpanda May 25 '11 at 0:31

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.