Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I cannot send or receive any emails from my server. I have checked the mailq and it has over 1100 emails. I have tried to run the following to flush the queue:

/usr/sbin/sendmail -q

But I get this error:

postqueue: fatal: Cannot flush mail queue - mail system is down

The mailq is full of emails from 'root' to 'root'. I have provided the maillog and mailq entries below. Does anyone know what could have happened?

I am running CentOS 5.5.

EDIT

Here is a paste of the most recent maillog entries. Also here is the contents of the mailq.

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

Looking at the log files, I'd say this is your problem:

2011-05-15T16:36:01.835702-07:00 ip-XXX-XX-XX-XX lmtpunix[19520]: verify_user(user.root) failed: Mailbox does not exist

Obviously if the mailbox doesn't exist, mail cannot be delivered. You'll have to either create an empty mailbox (with correct permissions and in the right place) or you'll need to put a working alias into /etc/aliases for root, and then re-run sendmail -q.

share|improve this answer
    
@woldgangsz - Thank you. So an email was received for root@mydomain.com? –  Christopher May 24 '11 at 15:54
    
@Christopher - please don't get me wrong: you can read English, right? It's all there in your log. And I would have to say that running a public mail server is something that does require a bit of determination and diligence, otherwise you'll soon become a statistic for the spammers. –  wolfgangsz May 24 '11 at 16:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.