Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have recently started moving some HG repos to a network drive. The HG web setup worked perfectly when the repos were on the local drive.

Old Setup:

  • C:\Repos\repo1
  • C:\Repos\repo2

the hgweb.conf had the following:

[paths] / = C:/Repos/*


New Setup:

  • //storage/repos/repo1
  • //storage/repos/repo2

the hgweb.conf has the following:

[paths] / = //storage/repos/*


When I then browse hgweb, none of my repositories show up in the list (the page renders fine, just no repos listed).

I have tried every combination of / and \ to no avail.

I don't think this is a permission problem as I have looked though filemon, and mercurial IS finding the paths, and reading the .hg directory for each. It's just not displaying them on the web.

I have also tried mounting the network path to a drive letter, and that also doesn't work.

Any help greatly appreciated =)

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

Just FYI, the problem with this was to do with the username that the Apache2 service was running under. Setting that up with a user that had permission to access the network path fixed the issue.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.