Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Windows 7, new computer. User's domain account is added to the Administrator group, but when running certain apps (for example, editing the hosts file using Notepad or running command prompt...) is giving the user permission issues. This has happened on a few machines, now. Sounds like it'd be a simple fix, just not sure how best to fix.

**EDIT - Permissions issues, for example when trying to save a hosts file after opening it, it won't save (i.e. trying to save via Ctrl+S). Running a command prompt action (see: running aspnet_regiis) gives an administrator permission issue.

This user's domain account is in the local Administrators group.

Thanks all

share|improve this question
    
Can you explain what you mean by "permissions issues"? –  joeqwerty May 24 '11 at 22:57
    
Hi Joe, see edit above. –  StephenPAdams May 24 '11 at 23:38
1  
Thanks for the clarification. It sounds like your issue is as charnley described. Even though the user is a local administrator, some functions require elevated permissions. You can get around this by using the "Run As" functionallity. –  joeqwerty May 25 '11 at 0:28

2 Answers 2

You are just seeing the new security with windows 7. even though the user is a member of the local admins group, you still have to "run as administrator" on some things to get them to work (like the command prompt if you want to do an ipconfig). The hosts file is set to read-only and secured in windows 7. Just change those settings and you can edit it all day long...

share|improve this answer
    
Charnley, thanks for the quick reply. How is it, though, that my account doesn't have these permission issues? I'm also in the local admins group. Is this because there's a local account on the computer with the same name that is an administrator? I.e. domain/user1 vs. user1 both having accounts on the machine? –  StephenPAdams May 25 '11 at 16:28
    
I believe that is correct... –  charnley May 29 '11 at 18:29

Everyone,

The issue appears to be UAC. If UAC is turned off, these permissions issues don't occur if the user is a local admin.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.