Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to upload a Windows 2008 SP2 server image to Amazon EC2, but once the process is complete, I can't connect to it.

  1. I had ops export a VMDK from our datacenter.
  2. The image appeared to have a fixed IP, so I loaded it in VMWare player and enabled DHCP.
  3. I uploaded it following amazon's instructions: http://aws.amazon.com/ec2/vmimport/
  4. I start the new instance and try to RDP to the public DNS; connection fails.

My two thoughts are:

  1. Loading it in VMWare player messed it up somehow, since the instructions say use an ESX image.
  2. The image they made me had the wrong network adapter type. The image has an Intel(R) PRO/1000 MT adapter using the E1G60I32.sys driver.
share|improve this question

3 Answers 3

up vote 0 down vote accepted

I have successfully imported a Windows Server 2008 R2 Enterprise vmware workstation image into EC2 through the following steps:

1) Removed all snapshots in vmware

2) Converted the VM's disk device to IDE via the following steps:

a) add a new disk of IDE type (no file splitting)
b) use Acronis True Image boot image (or any disk cloning tool) to clone the SCSI partition to the IDE partition
c) remove and delete the SCSI volume and vmdk file(s). 

3) Removed VMware tools

4) Enabled Remote Desktop Access

5) Converted VM to OVF using OVFTool

6) Created Import instance using EC2-import-instance

7) Uploaded VM using ec2-upload-disk-image

8) Waited until the Instance was converted. Started Instance.

9) Opened up RDP port using the security group's inbound rules.

10) Successfully connected via RDP.

It was a painful process, but it worked. Judging by what you revealed in your question, you may want to look into converting the disk type to IDE and well as streaming your image to OVF format.

share|improve this answer
    
My final stumbling block #9 -- opening up the port on the security group. –  remack Jun 28 '11 at 0:42
    
You say at #6 you created an import of your ovf file. There is no ovf format supported by the API tools so how did you do this? –  ing0 Mar 30 '12 at 14:54

There are some things we must remember when importing images to EC2 with the ec2-import-instance command:

  • We must have enabled Remote Access option before start the import
  • Know the Administrator password
  • Ensure that the Administrator user is able to use RDP
  • Create a Security Group or modify an existent one to enable needed ports for RDP.

Seems to be faster to convert VMDK images to Hiper-V images. So I installed the Starwind VMDK<->VHD converter http://www.starwindsoftware.com/converter and uploaded the converted to VHD image.

Remember to assign the security group in the command properties

-g [security group]
share|improve this answer

Got tons of problems with connectivity when tried VM import via ec2-api-tools myself. On your server:

  1. Allow RDP
  2. Disable Autologon
  3. Set non-empty Admin password
  4. Allow RDP connections from external networks in your Windows firewall settings
  5. Change the EC2 security group firewall rules to allow RDP
share|improve this answer

protected by Michael Hampton Oct 20 at 12:36

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.