Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a Virtuozzo VPS on a CentOS 4.4 box running Plesk 8.6. I upgraded MySQL from 4.1 to 5.0, but I had to use rpm -Uvh --nodeps to get around some Plesk packages that were dependent on mysqlclient14 specifically. I assumed they'd work fine once 15 was installed, because Parallels claims that there aren't any compatibility problems upgrading MySQL. The upgrade works and it looks like the MySQL is running fine, but now Plesk gives this error at the login screen:

ERROR: PleskFatalException  
Components::componentUpdate() failed: Unable to exec utility packagemng: Empty error message from utility.
0: /usr/local/psa/admin/auto_prepend/auth.php3:530

Here's the error log from Plesk's instance of Apache:

[root@hq 5.0-centosplus]# tail -n 20 /usr/local/psa/admin/logs/httpsd_error_log
...
[Tue May 24 15:41:07 2011] [error] Components::componentUpdate() failed: Unable to exec utility packagemng: Empty error message from utility.
/usr/local/psa/admin/bin/packagemng: error while loading shared libraries: libmysqlclient.so.14: cannot open shared object file: No such file or directory

/usr/lib/mysql/libmysqlclient.so.14 was replaced with libmysqlclient.so.15. How can I tell Apache/PHP it to use 15 instead of 14? I didn't see anything in httpsd.conf or php.ini.

I created symlink from the old 14 files in /usr/lib/mysql, but that didn't fix it. Now httpsd_error_log just says,

[Tue May 24 16:07:11 2011] [error] Components::componentUpdate() failed: Unable to exec utility packagemng: Empty error message from utility.
/usr/local/psa/admin/bin/packagemng: /usr/lib/mysql/libmysqlclient.so.14: version `libmysqlclient_14' not found (required by /usr/local/psa/admin/bin/packagemng)
share|improve this question
1  
From my knowledge, PLESK 8.6 isn't compatible with MySQL 5. I had some similar issues on one of my boxes and ended up having to update Plesk to 9.5.x to get around the problem, the alternative was rolling back to MySQL 4 (That was the advice given to me by Parallels) –  sam May 24 '11 at 20:12
    
If you check out the link I posted above, the first line says, "Plesk Control Panel fully supports MySQL 5 since Plesk 8.1 version." –  Ian Dunn May 25 '11 at 15:59

2 Answers 2

Install Atomic Rocket Turtle's RPM repository and type yum install mysqlclient14 mysqllibclient14. If it does not exist then:

  • yum install mysql
  • yum search mysql | grep client
  • yum provides mysqllibclient.so.14
  • yum install mysqlclient
  • yum install mysql-libs

You should be able to successfully run Plesk 8.6 with MySQL-5 by he way, I did it and it worked fine! I would recommend to remove ART's repository afterwards, no need to want to run the newest rpm's all the time, causes more issues than pleasure.

I had the same issue as you, but with mysqllibclient.so.15. If you need help, look me up in #plesk on irc.freenode.net.

share|improve this answer
    
I can't downgrade to .14 because the MySQL5 packages depend on .15. Also, Virtuozzo VPSs don't have yum, so I need to do everything with RPM. –  Ian Dunn May 26 '11 at 14:21
up vote 0 down vote accepted

I fixed it by copying libmysqlclient.so.14.0.0 and libmysqlclient_r.so.14.0.0 from another 8.6 box, chmod'ing them 755, and creating symlinks from libmysqlclient.so.14 and libmysqlclient_r.so.14, respectively. I also ran ldconfig afterwords, but I'm not sure if that's necessary or not.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.