Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I had an ISO file that was over 4GB. When I tried to copy or move the file from my computer to a USB key, I remember getting some error about the file being too large for the operating system to move.

So then I ran this command to have tar break it up into a disk1.tar and a disk2.tar:

tar -c -M --tape-length=2002400 --file=disk1.tar bigfile.iso

Once done, I copied the file onto USB. Now when I try to put the file back together, I ran the command:

tar -x -M --file=disk1.tar

But I get the error

tar: Archive value 4209604608 is out of off_t range 0..2147483647
tar: Exiting with failure status due to previous errors

So my question is how do I move a large file from my computer to a USB key? I even tried SFTP the file from one server to another, and it also complained about file being too large.

share|improve this question
    
What filesystems and what architectures are you using on each system? –  Scott Pack May 25 '11 at 0:33
    
If you're using FAT32, reformat it to another filesystem. –  Bart Silverstrim May 25 '11 at 0:57
1  
Where did you try SFTP'ing it to? Directly from server to server? There's no reason that a plain SFTP or SCP between servers should fail unless the filesystem were something like FAT32, then there's a possibility of it failing. What was the exact error, and how were you doing it? –  Bart Silverstrim May 25 '11 at 0:58

2 Answers 2

up vote 3 down vote accepted

If you have a network connection then just do a ssh pipe.

ssh user@host "cat > file.remote" < file.local

If you need to split the file for media then use split to break it up and cat to fuse it back together.

split -b 1G file.local filexfer
cat filexfer* > file.remote

Note that all this assumes that the remote filesystem is actually capable of storing files that large.

share|improve this answer

Not sure if you can reformat the USB key but if you can you should be able to put it there without splitting the file. The error was most likely due to the USB key being formatted with FAT32 which has a max file size limit of 2 GB. If you format it with ext3 or ext4 you will be able to write the entire file in one piece.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.