Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

One of my servers averages 566ms response time as measured by Pingdom ( pingdom.com ).

Is this a good score? Should I be doing more to optimise it?

share|improve this question
    
A "good" score is very subjective. Perhaps you could edit your question to ask about ways to optimize your server or how to look for bottlenecks. –  Chris Ting May 25 '11 at 14:53
    
Question revised... –  jnthnclrk May 25 '11 at 16:54
    
Pingdom traceroute: tools.pingdom.com/ping/… –  jnthnclrk May 25 '11 at 17:03
add comment

4 Answers 4

It is hard to tell without seeing the traceroute between the systems. Also, of course, if there are dialup links involved, it may also be reasonable.

Having said that, 566ms is sort of large. I get 510 ms over my Swedish ADSL link to a typical Chinese site, so if your site is a well-connected site in a data-centre in the West, you should probably expect less. For example, from a Swedish data-centre to a US East coast Amazon E2 host, I get less than 100 ms.

share|improve this answer
add comment

This is a very generic question, and the answer depends on the circumstances. If your server is connected via a satellite link, then 566ms are good. If your server is on a fast (e.g. 100MBit) connection (or hosted), then 566ms is bad.

To be helpful, you should run a traceroute (or tracert on Windows), and post the output. You may also want to use Visual Route (www.visualroute.com).

share|improve this answer
    
+1. The primary contributor to your round trip time should be the physical distance between the two locations. Unless you are heading to space and back twice in a round trip, there's likely something in the path adding delay; traceroute should help determine that. –  Shane Madden May 25 '11 at 15:01
add comment

This all comes down to your situation. Are you using an 9600 baud acoustic coupler on a payphone in Papua New Guinea? In that case, its fantastic. Are you using an OC48, directly connected to AT&T's fiber backbone? Then its terrible. What sort of connection? Are you using things like video/voice over IP? Anything UDP heavy? If so, you're going to run into problems at that latency. It'd work, it's just be a touch unpleasant.

share|improve this answer
add comment

If the applications or users are sensitive to high latency, no. Keep in mind that latency and throughput are not the same. It is possible for a high latency connection to have high throughput. Response time - latency - is a measurement of delay, not throughput.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.