Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When I activate a new rackspace ubuntu 10.04 instance I keep getting these messages:

perl: warning: Please check that your locale settings: LANGUAGE = (unset), LC_ALL = (unset), LANG = "de_DE.UTF-8" are supported and installed on your system.

How do I select and configure the locales correctly?

Edit: This was given to me by Rackspace support, it also worked, maybe it helps someone with ubuntu 10.04:

sudo locale-gen en_US.UTF-8
sudo /usr/sbin/update-locale LANG=en_US.UTF-8
share|improve this question

1 Answer 1

up vote 3 down vote accepted

First check that your desired locale is available on your system:

locale -a

If your locale is not available:

  • Find the line with your desired locale in /usr/share/i18n/SUPPORTED
  • Copy the whole line to /var/lib/locales/supported.d/local
  • Regenerate locales using sudo dpkg-reconfigure locales

Once the locale is made available, enable it by editing /etc/default/locale, e.g.:

LANG="en_US.UTF-8"
LANGUAGE="en_US:en"
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.