Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am receiving an error when trying to get a solution from subversion.

Here are the step I took:

  1. I edited the host file located here C:\Windows\System32\drivers\etc
  2. I added the the line 111.222.333.444 DEV.test.local
  3. In VS 2010 I chose Get Solution from Subversion
  4. I enter DEV.test.local/svn/Project1/trunk
  5. I enter me credntials (I know these credentials are fine bc i have used them before)
  6. I recieve this error: OPTIONS of 'https://DEV.test.local/svn/Project1/trunk': authorization failed: Could not authenticate to server: rejected Basic challenge (https://DEV.test.local)
share|improve this question
up vote 1 down vote accepted

1.) Make sure the changes were actually saved to the ../etc/hosts file because it is naturally "read-only" and must be changed with Administrator access.
- Also, make sure the line is not commented out with a "#" at the beginning.

2.) Assuming the changes to the "Hosts" file on your workstation are correct, does a ping test to "dev.test.local" resolve "111.222.333.444"?


 - "ipconfig /flushdns"    

and/or other commands to reset your network interface, if it does not resolve the IP.

3.) Are your credentials taking Domains or Workgroups into account?

4.) Check any recent changes to firewalls or network settings on both machines.

share|improve this answer
It resolves to the correct ip. No D/W with login. I dropped my firewall and attempted again with the same results. – dan_vitch May 27 '11 at 0:11

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.