Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am absolutely tearing my hair out with this one, largely as a result of not being able to find any real documentation on the topic. My box is ubuntu server, and my repository is fully browsable - I just can't perform a commit. My /etc/apache2/mods-available/dav_svn.conf looks as follows:

<Location /svn>

  DAV svn
  SVNPath /svn
  AuthType Basic
  AuthBasicProvider ldap
  AuthzLDAPAuthoritative off
  AuthName "Subversion Repository"
  AuthLDAPURL "ldap://dc0001/OU=Users,DC=dc0001,DC=unifybusiness,DC=local?sAMAccountName?sub?(objectClass=*)"
  AuthLDAPBindDN "CN=administrator,OU=Unify,DC=dc0001,DC=unifybusiness,DC=local"
  AuthLDAPBindPassword "REDACTED"

  #<LimitExcept GET PROPFIND OPTIONS REPORT>
    Require valid-user
  #</LimitExcept>

</Location>

and my rejection from the apache logs looks like this (I have tried authenticating myself as both "adusername" and "domain\adusername":

[error] [client 172.16.20.13] user unify\\ahand: authentication failure for "/svn/Misc": Password Mismatch
[error] [client 172.16.20.13] user ahand: authentication failure for "/svn/Misc": Password Mismatch

Any pointers someone might be able to offer would be very much appreciated - I am resorting basically to trying random combinations fo adjustments and that is no way to go on.

share|improve this question
add comment

1 Answer

The following link suggests that you should point your AuthLDAPURL to a Global Catalog server and use the port 3268 and not the standard 389

Also, look at your DC's Security logs, they might give you a clue as to what went wrong on that side.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.