Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am unable to connect to other machines with the same domain and network. SQL Server 2008 is running, I can connect locally with MSSQL01\Administrator and password using Windows authentication.

Although I would like other servers also to be able to access it... but it fails with the following error:

Login failed. The login is from an untrusted domain and cannot be used with Windows authentication. 

And how come after renaming the hostname and following instructions at, both MSSQL(old hostname) and MSSQL01 appear in sqlcmd -L.

C:\Documents and Settings\Administrator>sqlcmd -L

share|improve this question
Have a try using [SERVERNAME]\MSSQL01\Administrator – Danilo Brambilla May 27 '11 at 13:26

You do not say how they are trying to access it, but there is almost certainly a method to provide an alternative username and password, and you would want to specify MSSQL01\Administrator (in that exact form, unless there is a box for a domain). You are probably trying to connect as the administrator on the foreign host, which of course, is a different user, and does not have permissions.

share|improve this answer
They are trying to access it via an installer. Veeam on BACKUP, and vCenter on VCENTER. How do I make this work? It worked fine with MSSQL2005 on another machine. – ujjain May 27 '11 at 13:05

MSSQL01\Administrator is not a domain account (if I'm reading things correctly), it is a machine local account. You won't be able to use that account to authenticate to other domain machines, you'll need to use a domain account to do that.

share|improve this answer

Check the SQL server configuration manager>SQL server network configuration>Protocols.... Make sure that TCP/IP is enabled. Hope this helps.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.