Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I will be sending mail from my machine (just sending, not receiving any) I'm looking for a good guide that will help me configure it with all the things that are required so that receiveing servers will not ignore or block my emails. I've heard about DKIM and SPF that need to be setup, is there anything else? A decent guide for Debian 6 would be nice. BTW, my incoming mail is handled by google apps, I was wondering if this would conflict with my setup at all?

List of questions I have:

  • is there a nice guide out there?
  • do I need anything else other than spf records and dkim filters?
  • is it ok to have domain.com as server hostname and not host.domain.com
  • would using google apps for incoming mail interfere with my ourgoing mail setup?

Thanks

share|improve this question
1  
This is multiple questions, and isn't clear: nice guide for what? Postfix? SPF and DKIM? Debian? Postfix specifically on Debian? Also, although there's no canonical "how to make sure email is delivered" Q here, this is very close to: serverfault.com/questions/265361/… –  Ward May 28 '11 at 7:10
    
Is there a nice guide? Yes, there are many. How about putting a little effort in on your own and then asking specific questions if that becomes necessary. –  John Gardeniers May 28 '11 at 12:18

1 Answer 1

up vote 1 down vote accepted

I would start with the article from engine yard (they are offering to do it for you for a fee but it gives you a great idea of where to start) ...How to ensure your email gets delivered Next I would look at how to implement those things in your OS (in your case debian). When I did it it was under ubuntu but the guides should hold fairly well ...DKIM SPF

It is OK to have domain.com .. but only if that is the only thing you are doing with the domain ... I would recommend setting up mail.domain.com

Using google apps for incoming would be fine just make sure you set it as an authorized host

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.