Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm getting this new, strange error message in IIS after updating Windows 7 (x64) with SP1.

  1. Open the IIS Manager
  2. Browse to an exisiting Virtual Application (or create a new one)
  3. Open its Basic Settings dialog
  4. Click Test Settings
  5. The error message comes up

It's happening with new Applications and also with ones that were already there (and without that problem) before.

The applications themselves continue to work.

Has anybody figured this one out yet?

share|improve this question

migrated from stackoverflow.com May 28 '11 at 3:07

This question came from our site for professional and enthusiast programmers.

    
What path is your website root set to? * Does the path exist? * Does your IIS user have access to the path? * Try adding a simple .gif to the path. Can you access it? * If successful, try an ASP.NET page. Does it work? –  erikbra May 16 '11 at 22:15
    
@Erik, there are no problems opening the site in the browser, seeing the pages of images. The problem I'm asking about is in the IIS Manager. –  Anonymous May 18 '11 at 13:57
    
But, what does the error message say? Are you sure you're not using Integrated Security, and the IIS Manager is unable to test this, as you're not authenticated when running through IIS Manager? –  erikbra May 18 '11 at 19:15

7 Answers 7

Doublecheck that your specific version of ASP.NET is allowed in IIS as follows:

  1. Select the top (root) server in IIS Manager.
  2. Doubleclick ISAPI and CGI Restrictions.
  3. If your version of ASP.NET is Not Allowed, right click and Allow it.

This solved it for me, hope it works for you too.

share|improve this answer
    
Thank you. Many questions come out of this. I wonder why they make this the default. Why isn't this the first answer when looking up this error? the list goes on. –  Brad Bruce Jun 19 at 15:05

I had the same problem, solved by giving explicit permissions to IIS_IUSRS in the folder where my application is.

share|improve this answer
    
What explicit permission did you give. I tried giving it Full Control and it didn't help. Just to be clear, I had all the right permissions before Win7-SP1. Clicking Test Settings back then used to work just fine. –  Anonymous Mar 15 '11 at 16:50
    
Just Read, nothing fancy... –  Anonymous Mar 21 '11 at 0:33

I had same problem, here is my solution.

  1. Check the application pool your application is using.
  2. Click on application pool and click on Advanced settings, will lead to new window.
  3. Check the .NET Framework version
  4. Set Load User Profile to True
  5. Set ping enabled to True
share|improve this answer

Something that worked for me was to Allow 32bit applications on the applicationpool.

It seem that the application I ran was a 32bit one

HTH

share|improve this answer

I still haven’t find a solution, but find a workaround.

You can manually change IIS configuration, in system32\intsrv\config\applicationHost.config. Just manually create (copy-paste) section in and .

share|improve this answer
    
Your answer seems to be missing information. Might want to fix that, or remove it, if you don't want to be down-voted. –  Remi Despres-Smyth Apr 4 '13 at 13:07

Within IIS in the "Advanced settings" of the Application Pool(s), under "General" there is an "Enable 32-Bit Applications" setting. When I set that to True, this error went away for me.

share|improve this answer
    
I had tried that already. Tried again. Made no difference. –  Anonymous May 18 '11 at 13:59

IMHO ... This test is of little value unless you want to test a specific user and even then it's marginal ... to add user accounts to folders to allow this test to work (as others stated) marginalizes your security... better to not have this test then to add users to folders and jeopardize your security in any way, shape or form...

As long as your site works... that should be your benchmark...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.