Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I set up System Center Virtual Machine Manager some time ago. We barely use it, except to do conversions from VMWare to Hyper-V. When I initially set it up, it worked fine for this purpose. Now, when I try to do a V2V conversion, the job fails during the transfer of data over BITS; it says that the connection timed out. The source VM, destination, and SCVMM machine are all the same machine. I've looked at the event logs, and I see the URL that is trying to be accessed by BITS. I've popped that URL into my browser, and it doesn't work. I've tried packet captures, but the traffic never appears on any of the adapters since it is all loopback traffic. When I try the hostname of the URL in a manual telnet session to the SSL port, I get a connection, so I know something is listening. I checked the SSL cert bindings, and I beleive that a cert is bound. I don't get any errors in my browser regarding certs when I try. I did try trimming the URL up a bit, and I am getting 404 errors when I try the top level directory. However, SCVMM uses BITS for the transfer, not pure HTTP, so I may not be doing the right kind of test.

UPDATE: I tried it with a VMWare VM copied from a different server, it magically worked. So, somehow, SCVMM's ability to dish out the file is based on the file itself. I also tried to start the same said VM on a different machine, under VMWare Workstation, and it failed too. There is something very, very wrong here. It could have occured on the transfer to the SCVMM machine (I doubt it, I tried twice), or it could be something not right about VMWare Server.

Any help would be much appreciated! I've been banging my head on this for half of a week now.

Thanks!

J.Ja

share|improve this question

2 Answers 2

As I understand BITS - it's a sort of low-priority service. If other network traffic on that machine (presumably, the existing VMs) are saturating that bandwidth, BITS would (working as intended) never get a chance.

Do you have the luxury of suspending the other VMs to see if the timeouts persist?

share|improve this answer
    
Thanks Kara! That's a good point. Unfortunately, I don't have that luxury; we're not big enough to have two Hyper-V host machines. However, I do know that the load has only gone up a little bit since the last successful conversion, and bitsadmin shows that the jobs are always stalled at the same bytecount. And perfmon doesn't show anywhere near saturation. J.Ja –  Justin James Jun 17 '09 at 18:47
    
Ah well, it was a long shot. ;) If the BITS error isn't a red herring, technet.microsoft.com/en-us/library/cc720473(WS.10).aspx might help narrow things down. –  Kara Marfia Jun 17 '09 at 19:04
    
Thanks again! Last night, something hit me... I took the error code from Event Log (2147954402) which was returning zero useful hints, converted it to hex (80072EE2), and lo and behold, zillions of hits for people with Windows Update problems. Hopefully, their information will be applicable here... Unfortunately, that error code is not on the list in the document you linked too. :( –  Justin James Jun 18 '09 at 13:42
    
Ack, that error code just means "timeout", which I knew was going on. Oh well, back to where I started! –  Justin James Jun 18 '09 at 13:45
up vote 0 down vote accepted

I found the problem. I was using FTP to transfer the files (the VMWare host is in the DMZ, my SCVMM machine is in the LAN, and FTP is our preferred means of transferring data between the two zones). When we transferred the files with an external USB drive, it worked like a charm. My only possible explanation is that maybe something got transferred in ASCII mode that should have been sent in binary mode.

Bizarre.

J.Ja

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.