Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

About 90% of the time when I mount a TrueCrypt share I get a blue screen of death. The error codes I see in the BSOD vary. The last two I saw mentioned eamon.sys and irql_less_than_or_equal.

  • Windows 7 Professional
  • TrueCrypt 7.0a
  • I am not using the EXT2 driver

Googling didn't turn up much, but hinted at TueCrypt + NOD32 issues. I tried disabling NOD32 real time monitoring during mounts, but it didn't help. How can I determine the cause?

share|improve this question
Have you tried disabling NOD32? Being that eamon is part of NOD32, I would try disabling it and see if it stops the BSOD. If so, maybe check to see if there is an update for NOD32 or open a ticket with them. A google search returns LOTS of BSOD issues in Win7 with NOD32. – Chris May 28 '11 at 15:57
I did, and it didn't help. At this point I'm about ready to move to Mac. Seriously. – Justin Jul 10 '11 at 23:32

UPDATE: The problem reoccurred; this didn't fix the issue.

Disabling NOD32 didn't help. The solution was to set the exe of TrueCrypt to Windows Vista SP2 compatibility.

  1. Go to the installation folder for TrueCrypt

    C:\Program Files (x86)\TrueCrypt

  2. Right click TrueCrypt.exe
  3. Go to the Compatibility tab
  4. Check "Run this program in compatibility mode for:"
  5. Set it to Windows Vista SP2

share|improve this answer
Good on you for coming back and posting your solution (correctly as well) after an extended period of time :) – Mark Henderson Jul 10 '11 at 23:18
@Mark - Thanks! But of course, after it not happening many times, I posted this answer and it BSOD'ed earlier today. Ugh. – Justin Jul 10 '11 at 23:31

This seems to be an on-going issue. Please check the official support forums for further information.

A couple of posts indicate that by doing this, it may resolve your issues:

  1. Disable boot sector scanning OR
  2. Deactivating "Automatic startup file check" under schedule


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.