Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to install ionCube loader on a CentOS 5 machine.

I've installed php 5.3 & ionCube loader through the atomic yum repo.

when i check on the command line, php says ionCube loads fine:

php -v
PHP 5.3.6 (cli) (built: Apr 19 2011 12:28:40) 
Copyright (c) 1997-2011 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2011 Zend Technologies
    with the ionCube PHP Loader v4.0.5, Copyright (c) 2002-2011, by ionCube Ltd.

but the loader isn't picked up when I run a php script via http (?)

phpinfo() shows in the "Additional .ini files parsed" that /etc/php.d/ioncube.ini is indeed loaded and parse but ionCube doesn't work; ionCube encrypted files are shown as is rather than parsed and the phpinfo page shows no mention of ionCube (apart from the parsed ini file).

I've restarted apache.

What's missing?

EDIT: The ioncube.ini file content is:

zend_extension=/usr/lib/php/ioncube/ioncube_loader_lin_5.3.so

EDIT 2: just tried zend gard loader and it worked right away. ionCube does not. Weird

share|improve this question

1 Answer 1

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.