Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

In Active directory, when I try to connect to another domain controller, after adding that domain controller and press ok, a message appears to me:

The following domain controller could not be contacted, the RPC server is unavailable

How can I fix this problem.

share|improve this question
If you want good quality help, you may need to improve your question a little. What have you tried so far? Can you ping one server from the other? Can you map a drive? Is the time + timezone correct on both of them (have you CHECKED, not assumed?). Are there any errors in the event log? –  RobM May 29 '11 at 11:54
How have you added the domain controller? To what have you added it? How are you trying to connect to it? –  John Gardeniers Jun 9 '11 at 5:12

1 Answer 1

I agree with others that your questions is definitely not clear enough; anyway, since I've been fighting with a similar issue for all yesterday, I feel compelled to answer.

This can depend on a lot of things:

  • Can the two computers actually talk to each other? Check with ping, mapping a network share, etc.
  • Are they on the same subnet or on different ones? If they are on different ones, is there a firewall in the middle?
  • Is the first domain controller (and the domain as a whole) operating correctly? Can you f.e. succesfully log on to domain computers, browse AD, etc.? You can perform a full check on them with DCDIAG.
  • Is DNS consfigured correctly on the new DC? Does it use as its DNS servers the domain's already existing domain controllers, and only them (no external DNSs please!)?
  • Is the tyme sync ok between the new DC and the current ones?
  • Is the new DC already a domain member? If not, can you try joining it to the domain and then performing the DCPROMO after this is done (and logged in as a domain admin)?
  • Related to the preceeding item: how are you logging in to the domain? I've been getting exactly that error because I was running DCPROMO with a local Administrator on the new DC, so I had to specify domain credentials for the promotion... and someone had filled the "domain" field with the domain's FQDN instead of the NetBIOS name. Everything was working perfectly, but I kept getting that "RPC server is unavailable" (quite misleading, BTW).
share|improve this answer
Not sure if it helped the OP, but your last bullet (NETBIOS vs. FQDN) helped me out. I'm still not sure why I can't Change Domain Controller using FQDN, but at least I can work around it with NETBIOS name instead. Thanks! –  Rob D. Apr 18 '13 at 14:51

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.