Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using PHP5.3 as module for Apache2.2(Windows). For one virtual host i need use PHP4 as CGI for .php files. This is my config

<VirtualHost *:80>
DocumentRoot "E:\projects\php\wp\dev"
ServerName wp.dev4

AddHandler php4-script .php
Action php4-script "E:\server\bin\php-4.4.9\php.exe"
<Directory "E:\projects\php\wp\dev">
  Options ExecCGI
  AllowOverride All
  Order deny,allow
  Allow from all

But I get error

The requested URL /server/bin/php-4.4.9/php.exe/test.php was not found on this server.

What's the problem?

share|improve this question

migrated from May 29 '11 at 16:11

This question came from our site for professional and enthusiast programmers.

How does test.php related to what you're doing? – Chris Ting May 30 '11 at 5:15
Im just runing wp.dev4/test.php. – Kein May 30 '11 at 7:06

It looks like you're missing a Directory block to give permissions to access the directory your PHP CGI is in: E:\server\bin\php-4.4.9

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.