Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Trying to install Fedora 15 via a live USB made with unetbootin. I get to the unetbootin boot menu, select, I get to this screen, then it drops into a debug shell with the message sh: can't access tty: job control turned off. The last message is dmseg is dracut Warning: No root device "live:/dev/disk/by-label/" found.

Seems to be the same problem detailed here. Tried to try nk1eto's solution but there is no by-label directory in /dev/disk. There's by-id, by-path and by-uuid.

share|improve this question

I was getting the exact same error, but I was using usb-creator.exe.

Solution: Use MultiBootUSB script:

I now am typing this from within Fedora 15 x64-Live-Desktop!

share|improve this answer

When the installer starts to boot hit Esc. This will cause it to show messages normally hidden behind the "pretty" blue screen and will give you more information. I think you may be on the right track, though.

This HOWTO could help you. There's a section on labelling a partition on your USB too. Use output of mount and/or dmesg to determine, which partition is your USB stick.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.