Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Having some trouble with my NICs. The server starts fine and I can wget/ping etc. However, when I /etc/init.d/networking restart I then receive the following error:

Bringing up interface eth0: bnx2: fw sync timeout, reset code = 1030009
SIOCSIFFLAGS: Device or resource busy

Consequently, the task fails. I have searched around on google users suggesting to disable PNP in the BIOS but I see no option. Here is some system information:

$ ethtool -i eth0
driver: bnx2
version: 2.0.8-rh
firmware-version: bc 2.9.1

$ uname -a
Linux host 2.6.18-238.9.1.el5 #1 SMP Tue Apr 12 18:10:13 EDT 2011 x86_64 x86_64 x86_64 GNU/Linux

$/sbin/lspci | grep Broadcom
04:00.0 PCI brodge: Broadcom EPB PCI-Express to PCI-X Bridge (rev c3)
05:00.0 Ethernet controller: Broadcom Corporation NetXtreme II BCM5700 Gigabit Ethernet (rev 12)
08:00.0 PCI brodge: Broadcom EPB PCI-Express to PCI-X Bridge (rev c3)
09:00.0 Ethernet controller: Broadcom Corporation NetXtreme II BCM5700 Gigabit Ethernet (rev 12)

$ lsmod | grep bnx2
bnx2i                  81704  0 
cnic                  109512  1 bnx2i
libiscsi2              77765  6 be2iscsi,ib_iser,iscsi_tcp,bnx2i,cxgb3i,libiscsi_tcp
scsi_transport_iscsi2    73945  8 be2iscsi,ib_iser,iscsi_tcp,bnx2i,cxgb3i,libiscsi2
bnx2                  224780  0 
scsi_mod              199001  15 mpt2sas,scsi_transport_sas,mptctl,be2iscsi,ib_iser,iscsi_tcp,bnx2i,cxgb3i,libiscsi2,scsi_transport_iscsi2,scsi_dh,sg,libata,megaraid_sas,sd_mod

$ rmmod bnx2; modprobe bnx2
PCI: Enabling device 0000:05:00.0 (0158 -> 015a)
PCI: Enabling device 0000:09:00.0 (0158 -> 015a)
bnx2: fw sync timeout, reset code = 10300003

Any help would be appreciated as I am at a loss.

share|improve this question
    
You may have a hardware issue. Do you happen to have a spare NIC to swap out? What's the model of the bnx2 card (/sbin/lspci)? –  Fanatic May 30 '11 at 0:56
    
Thanks, for your help - I have updated my post with your request. –  james moore May 30 '11 at 9:12
    
It's been a while but I remember having to do a song and dance to get this NIC to work. Do a lsmod |grep bcm57 and see if the kernel module is loaded. If not, then you will need to install it. Should be on the install DVD. For some reason the bnx2 driver didn't work for me. –  ablackhat May 30 '11 at 9:37
    
Since posting I have now updated the BNX2 driver version to: 2.0.23b, still the problem persists. I will take a look at your suggestion. BTW lsmod | grep bcm57 returns nothing. –  james moore May 30 '11 at 10:09
    
I see - I'll update the firmware too. –  james moore May 30 '11 at 10:12

3 Answers 3

It's possible you're hitting one (or both) of these bugs:

Try the latest kernel from jwilson:

share|improve this answer

I have been having some issues with these bnx2 based cards. A fix for me was blacklisting the bnx2i module (this one does iSCSI offloading). If you don't need iSCSI offloading, try unloading bnx2i and blacklisting it in modprobe.conf.

share|improve this answer

PROBLEM: Once OMSA loads, the management tools lose communication with the NIC. (IPMI seems to be involved)

Solution:

srvadmin-services.sh disable
shutdown -r now
update_firmware --yes
srvadmin-services.sh enable
shutdown -r now

Find the following link http://lists.us.dell.com/pipermail/linux-poweredge/2011-November/045577.html

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.