Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've registered a .de domain but when I try to change the nameservers to those of the hosting company I wish to use I get the following error:

> Command failed; [53300102912
> Nameserver error [ERROR: 116 SOA
> record response must be authoritative
> (resolver\, answer)
> (\[/10.121.46.7|/2001:608:6:7:4:0:0:11\]=>85.92.74.12:53
> (UDP\, PROTOCOL_EXPLICITLY_CHOSEN\,
> Timeout: 3s\, Retry: 1 x 0s\,
> unsecure\, ignoreTC)\,
> \[/10.121.46.7|/2001:608:6:7:4:0:0:11\]=>85.92.74.12:53
> (UDP\, PROTOCOL_EXPLICITLY_CHOSEN\,
> Timeout: 3s\, Retry: 1 x 0s\,
> unsecure\, ignoreTC): )]]
> 
> If you wish to change your
> nameservers, you need to make sure
> they are configured according to DENIC
> (the .de registry) rules.

It also points me at the DENIC website nameserver check which tells me that the domains fail, much the same error as above, as is expected.

So the question is, what do I need to do? Is it something that my hosting provider will need to sort out with their nameservers, or can I do something about it myself?

Any thoughts and help much appreciated. Thanks in advance.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Check at your hosting company if the DNS was configured as a master server for your domain. If you added entries (A, CNAME, etc.) it should have been, but it seems to be answering that it's not authoritative for it.

This shows that the domain has other name servers configured right now (ns and ns2.123-reg.go.uk):

$ dig ns iandevlin.de 

; <<>> DiG 9.7.3 <<>> ns iandevlin.de
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 9583
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 2

;; QUESTION SECTION:
;iandevlin.de.                  IN      NS

;; ANSWER SECTION:
iandevlin.de.           86376   IN      NS      ns.123-reg.co.uk.
iandevlin.de.           86376   IN      NS      ns2.123-reg.co.uk.

;; ADDITIONAL SECTION:
ns.123-reg.co.uk.       7066    IN      A       212.67.202.2
ns2.123-reg.co.uk.      7066    IN      A       92.51.159.40

;; Query time: 12 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Mon May 30 08:33:23 2011
;; MSG SIZE  rcvd: 110

This shows that the DNS of your hosting service is not answering queries for your domain (85.92.74.12 is the DNS of your hosting service, right?):

$ dig @85.92.74.12 iandevlin.de

; <<>> DiG 9.7.3 <<>> @85.92.74.12 iandevlin.de
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 16387
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 13, ADDITIONAL: 13
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;iandevlin.de.                  IN      A

### (snip)

;; ADDITIONAL SECTION:
a.root-servers.net.     599044  IN      A       198.41.0.4
a.root-servers.net.     599044  IN      AAAA    2001:503:ba3e::2:30
b.root-servers.net.     599044  IN      A       192.228.79.201
c.root-servers.net.     599044  IN      A       192.33.4.12
d.root-servers.net.     599044  IN      A       128.8.10.90
e.root-servers.net.     599044  IN      A       192.203.230.10
f.root-servers.net.     599044  IN      A       192.5.5.241
f.root-servers.net.     599044  IN      AAAA    2001:500:2f::f
g.root-servers.net.     599044  IN      A       192.112.36.4
h.root-servers.net.     599044  IN      A       128.63.2.53
h.root-servers.net.     599044  IN      AAAA    2001:500:1::803f:235
i.root-servers.net.     599044  IN      A       192.36.148.17
i.root-servers.net.     599044  IN      AAAA    2001:7fe::53

;; Query time: 240 msec
;; SERVER: 85.92.74.12#53(85.92.74.12)
;; WHEN: Mon May 30 08:33:52 2011
;; MSG SIZE  rcvd: 497

So double-check the configuration on your hosting provider and make sure you're using the right domain name servers.

share|improve this answer
    
Hmm you have me at a disadvantage here, as I'm not great with such things and you may need to explain things a bit more! Where should I run dig from? –  Ian Devlin May 30 '11 at 10:40
1  
@Ian - I should've been clearer, of course! You can run dig from any Linux server. The Windows equivalent is, I think, nslookup; but it has a different syntax. –  Eduardo Ivanec May 30 '11 at 10:42
    
Thanks. I'm still a bit confused sadly. –  Ian Devlin May 30 '11 at 10:54
    
That command lets you see yourself the DNS response from your hosting service. The idea is to check for anomalies or errors reported directly by the hosting provider. You can post the domain name and I'll check it if you want. –  Eduardo Ivanec May 30 '11 at 10:59
1  
I thought you were trying to make the change on DENIC itself, sorry. If you configure it right the hosting provider's DNS should answer queries independently of whether it's already the "primary" nameserver (pointed by 123-reg) or not. So check there. –  Eduardo Ivanec May 30 '11 at 11:51
show 7 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.