Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a server running 9.04 and I'd like to upgrade it to 9.10 (on the way to getting to the latest version). However, despite following the nice documentation, I am unable to.

Specifically, sudo do-release-upgrade fails:

Checking for a new ubuntu release
Done Upgrade tool signature
Done Upgrade tool
Done downloading            
extracting 'lucid.tar.gz'
authenticate 'lucid.tar.gz' against 'lucid.tar.gz.gpg' 
tar: Removing leading `/' from member names

Reading cache

Checking package manager

Can not upgrade 

An upgrade from 'jaunty' to 'lucid' is not supported with this tool. 

My original /etc/apt/sources.list:

## EOL upgrade sources.list
# Required
deb http://old-releases.ubuntu.com/ubuntu/ jaunty main restricted universe multiverse
deb http://old-releases.ubuntu.com/ubuntu/ jaunty-updates main restricted universe multiverse
deb http://old-releases.ubuntu.com/ubuntu/ jaunty-security main restricted universe multiverse

# Optional
#deb http://old-releases.ubuntu.com/ubuntu/ jaunty-backports main restricted universe multiverse
#deb http://old-releases.ubuntu.com/ubuntu/ jaunty-proposed main restricted universe multiverse

Changing jaunty to karmic and old-releases to releases gives 404 errors when I run sudo aptitude update. And, sudo do-release-upgrade still tries to upgrade directly to lucid.

share|improve this question
    
Did you run sudo apt-get install update-manager-core? Just went through the multiple upgrades required going from 8.10 to 10.04LTS, had no issues. –  gravyface May 30 '11 at 12:08
    
I'm not sure but I just tried it now and that didn't help. –  pr1001 May 30 '11 at 12:22
add comment

3 Answers

up vote 3 down vote accepted

Probably too late but....

Changing jaunty to karmic and old-releases to releases gives 404 errors

This should be old-releases to archive

share|improve this answer
    
It's never too late for a correct answer, especially considering that I haven't marked any answer as correct yet. Testing archive now but already it's looking very good. –  pr1001 Jun 7 '11 at 10:23
    
That did the trick. I then had some problems rebooting but found a work-around. –  pr1001 Jun 7 '11 at 14:13
    
Happily I've got my 8.04 all the way up to 10.04 now! –  Simon Pickles Jun 7 '11 at 14:47
add comment

This upgrade will not work at all!
From the ubuntu-security-announce mailing list (received last week):

This note is just to confirm that the support period for Ubuntu 9.10
(Karmic Koala) formally ended on May 1, 2011 and Ubuntu Security Notices
no longer includes information or updated packages for Ubuntu 9.10.  

Hence the 404's.
"Cruel workaround": replace all "jaunty" 's in /etc/apt/sources.list and /apt/sources.list.d/* with "lucid" and run "aptitude update && aptitude dist-upgrade"

share|improve this answer
    
Wow, that's very weird especially considering that 9.04, a non-LTS version (right?) is still available, albeit under old-releases, and that 9.10 is available under releases: releases.ubuntu.com/karmic –  pr1001 May 30 '11 at 14:26
1  
Are you looking for some kind of fix to get to "Lucid" or for an explanation..? –  Henk May 30 '11 at 17:57
    
I'm looking for a fix to get to Karmic. Your explanation makes sense but still I find it hard to believe given that older releases are still on old-releases. Not your fault, of course! –  pr1001 May 31 '11 at 13:01
add comment

I see do-release-upgrade is automatically trying to upgrade to Lucid, which is wrong (maybe a bug, as the docs don't point out this possibility).

Check /etc/update-manager/release-upgrades. Does it say Prompt=lts? If so, try changing it to Prompt=normal.

If all fails you can try upgrading the Debian way - by modifying your sources to point to Karmic and doing apt-get update && apt-get dist-upgrade.

share|improve this answer
    
That is what I am trying to do, upgrade to 9.10. I have no clue why it's trying to jump to Lucid. –  pr1001 May 30 '11 at 12:23
    
Try changing /etc/update-manager/release-upgrades as per the edit, does it help? –  Eduardo Ivanec May 30 '11 at 12:45
    
Thanks but it already says Prompt=normal. –  pr1001 May 30 '11 at 14:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.