Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am able to browse shares and, sometimes, connect my outlook to the exchange server when connected over VPN to my office's LAN. However I am aware my VPN address is in a completely different subnet to that the server is on. (my server is something like 192.168.0.1 whereas my VPN is 5.*)

The problem is exchange and accessing shares can be slow typically at first and exchange often drops out - I think because more needs to be configured on the Windows server 2003 box for domain lookups?

EDIT: I see someone tried to close this question?! Let me rephrase:

How should one configure the DNS lookupzones to allow quick resolution of my local domain from a different subnet?

share|improve this question

2 Answers 2

A VPN connection is probably going through a WAN with higher latencies and lower throughput, so a performance hit is expected when browsing shares.

It does not matter (much) if your VPN client gets an address from a different subnet when connecting. If you are able to browse shares and connect to Exchange, you probably have set up DNS correctly, but you could double-check by trying to resolve some domain-internal DNS RRs at your VPN client as described in the documentation:

nslookup
[...]
> set q=srv
> _ldap._tcp.dc._msdcs.your-ad-domain.local

If it resolves to your domain controller(s), everything is fine. If not, it obviously belongs changed. How to set up a DNS server for a VPN client depends on your VPN implementation. If you could add the details to your question, someone is likely to give you some advice.

If you are using Windows RAS (e.g. PPTP VPNs terminated at your Windows Server), you would need to add the DNS server information for your AD as the first entry in the RRAS DNS Service search order configuration. The resolution of short names will not work with this configuration, though - it does not support the assignment of domain search lists, so you will have to use FQDNs for name resolution.

share|improve this answer
    
Thanks, the nslookup does not succeed! (I knew something was wrong).. It seemed to just query my Internet DNS.. My VPN connection has a gateway of 5.0.0.1 and does not have any DNS... –  user55029 Jun 1 '11 at 2:57
    
This is likely to be your main problem then. I've posted some additional information on this topic to my answer article - feel free to provide further configuration information. –  the-wabbit Jun 1 '11 at 12:17
up vote 0 down vote accepted

I had to manually enter a DNS on the VPN connection then move the VPN connection priority to the top so it was queried before my other connected interfaces:

Network Connections > Advaced Settings

NOTE: For Hamachi follow this too: http://logmeinwiki.com/wiki/Hamachi:Microsoft_Exchange_Server_connection

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.