Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am new to RHEL 6 but have a project where I need a postgres 9 database and I only have RHEL 6 available to me. How can I safely do this? Should I install from source or is there a package around somewhere?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

To install open-source version of PostgreSQL you have three ways:

Note that if you are doing something serious, then you probably should use latest minor version of PostgreSQL (at this time 9.0.4).

share|improve this answer

You can use the official RPMs available directly from PostgreSQL at: http://www.pgrpms.org/

Find the repo file for your preferred distribution and install from there.

Also see: PostgreSQL RPM Building Project - Yum Repository Howto

share|improve this answer
    
Did you specifically want to compile from source? You mentioned Red Hat 6, so I thought you'd be interested in an RPM-based solution. –  ewwhite Jun 1 '11 at 16:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.