Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have just deployed a Windows 2008R2 server in our Windows 2003 domain. XP clinets are unable to browse in "entire network" and find the new server. It can be accessed by entering \\servername and it can be pinged by name and IP address. Users access shares without issue. Netbios over TCP/IP is enabled. Computer browser is running on the Windows 2008R2 system. Turn on Network Discovery is enabled.

These services were started as a result of an MS article

  • Computer Browser
  • DNS Client
  • Function Discovery Resource Publication
  • SSDP Discovery
  • UPnP Device Hosts
share|improve this question
    
any GPO constraints? –  Keith Jun 2 '11 at 12:13
    
None that we can identify from RSOP –  Dave M Jun 2 '11 at 16:43

5 Answers 5

Do you have more than a single network / broadcast domain in your setup? If so, you will need to have a WINS server and set up your clients and your servers to point to it in order to have them all correctly appear in the browsing list.

You should use the browstat.exe tool from the XP SP2 support tools for further troubleshooting - especially to determine your current subnet's Master Browser and the Domain Master Browser.

Even if you've started the Browser service on the Windows Server 2008, it may well be that it is somehow prevented from sending or receiving the NetBT browsing announcements and request packets - if you are using a firewall or have the Windows Firewall enabled consider disabling it for testing purposes.

share|improve this answer
    
Firewall is disabled. Even clients on the same subnet are unable to browse for the new server. –  Dave M Jun 1 '11 at 20:36
  1. Did you enable Network Discovery on the W2K8 server?

  2. Why is it important to be able to find the server in Network Neighborhood or My Network Places?

share|improve this answer
    
Network Discovery is enabled. Corrected error in OP. Users request this is the simple answer. Have found many other posts in other forums on this so it seems a common request. Necessary, not so sure. –  Dave M Jun 2 '11 at 12:06

As mentioned, WINS helps out a lot with this. Does your windows 2008 box have any WINS servers configured under it's TCP/IP properties? If you're not using WINS, and the server / client are on different vlan's, then I don't think the XP client will be able to see Windows 2008 box. Netbios works by broadcasts, and broadcasts aren't passed across vlans's typicaly. This is where WINS comes into play. If they're on the same subnet, check the TCP/IP properties of the network adapter (on both boxes) and ensure that netbios is set to default.

Try this, from the windows xp box, run the following command "nbtstat -a server" (server being the name of your windows 2008 R2 box). if nothing comes back, netbios isn't working and thus your network places will not work.

share|improve this answer
    
nbtstat -a reports the server as Type Unique and Status registered. –  Dave M Jun 6 '11 at 11:58

Have you run through to verify the XP and server machines are using the same master browser?

http://support.microsoft.com/kb/188305

Is the firewall on the server using the Domain profile and is the Network Discovery service allowed?

share|improve this answer
    
Firewall is off and Network Discovery is on. –  Dave M Jun 7 '11 at 12:48

Sounds like the XP clients are configured to prefer NetBIOS name resolution. Disable NetBIOS over TCP/IP (NBT) on the clients.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.