Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I was noticing a issues with the server.

Usually Microsoft Updates that have downloaded, but are waiting to be installed can cause this.

Before applying the updates and restarting, I ran several diagnostic tests on the hardware and everything came up green. Both hard drives also displayed green lights

I then chose 'Install updates and Restart'.

Upon reboot, immediately after the 'SCSI scanning' hits 100%, both hard drives go from green to blinking amber and I get a '1 logical drive found/failed' error message.

I've tried reseating the drives without any change.

I've mounted two new drives in slots 2 and 3 (The two original drives are still in slots 0 and 1)

Would it be possible to rebuild/recover anything at this point?

If there is any possible step I'm missing before reinstalling the OS on the two new drives and starting from scratch, I'd REALLY REALLY appreciate someone schooling me on it before I kill any chance of recovery.

Thanks.

share|improve this question
add comment

4 Answers

well, 2800 is rather old now, but still, it would help if you posted the raid configuration and the state the disks are reported in, in the scsi controller bios. In general, the drives might be ok (they did pass the diags, right? you ran the dell pediags/onlineDiags from support.dell.com?) and you might just need to recover the array and possibly update the controller and disk firmware, but without any information, it's very hard to guide you through the required steps

share|improve this answer
    
Agreed, what is the scsi controller bios reporting? –  Aaron Jun 1 '11 at 20:27
    
Yes, the 2800 has done its duty. We're ordering a new server but I's love to have this one as a dev server. Its a RAID1 (two mirrored drives) I have two new drives now too. The original drives were offline after the restart, but I was able to force them back online and it's currently checking them for consistency. –  user779887 Jun 1 '11 at 20:51
    
ok, for a raid1, I'd try to recover one disk (leaving the other outside the machine), so that I'd get a degraded array - this way I'd still have the data. If the disk doesn't recover, well, you have the other one to try with. Once the array recovers, add the second disk and rebuild, then run diags again, and make sure you update the firmware. –  dyasny Jun 1 '11 at 21:01
add comment

Call dell tech support (or someone else who knows about RAID recovery) if you value your data.

share|improve this answer
    
I could not agree more. I feel like I know a lot about this stuff, but whenever I am in a similar situation, I still call. A second set of eyes, one that does nothing but that kind of problem all day long, cannot hurt. –  KCotreau Jun 1 '11 at 21:19
    
I did try for about 40 minutes with Dell support. But since the service plan has expired, he couldn't go too much further than giving me a few links to creating a boot disk etc. He said it's beyond their support level. And that's perfectly fine, the server is almost 7 years old. –  user779887 Jun 3 '11 at 6:10
add comment

I find it pretty implausible that a Windows Update caused the type of hardware problem you're experiencing, unless the Windows Update updated the firmware of the RAID controller or the HDD's themselves, which isn't likely as I've never seen a firmware update come through Windows Updates. If Windows Update updated the RAID controller driver then at it's worst it would cause Windows not to boot but wouldn't cause the POST errors you're having.

Did you run the diags from Windows? If so, you might want to download the Dell bootable diags, burn a CD, boot to it, and run them. That eliminates the OS from having any influence on the diags.

http://support.dell.com/support/downloads/download.aspx?c=us&cs=04&l=en&s=bsd&releaseid=R212797&SystemID=PWE_PNT_2800&servicetag=&os=WNET&osl=en&deviceid=196&devlib=0&typecnt=0&vercnt=16&catid=13&impid=-1&formatcnt=0&libid=13&typeid=-1&dateid=-1&formatid=-1&source=-1&fileid=301057

share|improve this answer
    
I didn't necessarily mean to imply that the windows updates caused the disk errors, I was just describing what happened before the crash. Though I have experienced OS issues with windows updates that were sitting in the queue. I have the 32 Diag disk, but the consistency check was still running when I left. I won't be able to run the diag again until tomorrow morning. I'll post the results then. Thanks everyone. –  user779887 Jun 1 '11 at 23:59
    
Gotcha. I misunderstood your point about Windows Updates. Keep us posted. –  joeqwerty Jun 2 '11 at 0:04
add comment

Okay, I "force online"'d my original two drives. I was also able to boot up into sbs 2003. The strange part is that it looks like the first drive was kicked offline back in Dec (indicated by the windows backup file) and that's what it booted up to.

I'm assuming the remaining drive has been operating on it's own since that time. (Before the crash I had seen that it had successfully created a backup file the night before) If I take one of the original drives back offline and it's successfully reboots to the other, I'm assuming I may be able to get access to the more recent data?

OpenManage Array Manager Displays:

MYSERVER
 -Arrays
  -PERC Subsystem 1
   -PERC 4e/DI Controller 0
    -Array Group 0
      Array Disk 0:0 Status: SMART: Failure predicted, online
      Array Disk 0:1 Status: SMART: Failure predicted, online
      Array Disk 0:2 Status: Online
      Array Disk 0:3 Status: Online
    -Virtual Disk 0
      Array Disk 0:2
      Array Disk 0:3
    -Virtual Disk 1
      Array Disk 0:2
      Array Disk 0:3
   -Backplane (Channel 0)
     Array Disk 0:0
     Array Disk 0:1
     Array Disk 0:2
     Array Disk 0:3
   -Channel 1

Could I clone the info from 0 & 1 onto 2 & 3 at this stage?

share|improve this answer
    
I've copied the .bkf that I currently have access to onto one of the workstations. So at least I have that much so far. If I could get it to boot into the other original drive (if the data wasn't overwritten by this one, I should be able to copy the more recent.bkf) –  user779887 Jun 3 '11 at 6:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.