Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm unable to connect to my localhost on port 80 while running WAMP at a hotel. Has anybody had these sorts of issues before? I'd like to be able to do some development work during my stay.

I realize that my WAMP server may be restricted from serving pages between computers...and why this might be a restriction. But certainly, I should be able to do a simple loopback so that PHP can run in the browser?

Connecting to http://localhost/ gives an 'unable to connect' message in the browser.

I've tried both wireless and wired internet options.

any ideas? services to check? tests to run?

share|improve this question

closed as off-topic by Tom O'Connor Aug 10 '13 at 21:04

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions must be relevant to professional system administration. Server Fault is a site dedicated to professionals; novice questions are off-topic. Please see the Help Center for more information on topicality. The best advice we can give you is to hire a professional to help you out." – Tom O'Connor
If this question can be reworded to fit the rules in the help center, please edit the question.

add comment

2 Answers 2

  1. Your Apache Service might not be running.

  2. Try http://127.0.0.1/ , it could be "localhost" is not resolving (for whatever reason).

The only other thing I can think of is that your browser has had it's proxy settings set.

share|improve this answer
1  
Agreed, the hotel setup should have zero effect on localhost/127.0.0.1. –  KCotreau Jun 1 '11 at 21:16
add comment

Things that I can think of

  1. Misconfigured proxy settings - You have to specifically tell your browser what not to send to the server (at least in Firefox you do). By default it doesn't send localhost or 127.*, but this may of changed. Check the settings. Note that FoxyProxy in Firefox has this issue
  2. No entry in hosts file - Don't know why this would of changed, but check your hosts file and see if 127.0.0.1 localhost is there
  3. Old cache - Maybe your browser is caching something weird. Clear it, restart the browser, and see if its fixed
share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.