Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am using Debian OS with pptpd. My clients (both Windows and Mac) cannot complete the connection.

The following shows in syslog:

Jun  2 12:52:37 vpn pptpd[891]: MGR: Maximum of 6 connections available
Jun  2 12:52:48 vpn pptpd[892]: MGR: Launching /usr/sbin/pptpctrl to handle client
Jun  2 12:52:48 vpn pptpd[892]: CTRL: local address = 192.168.30.91
Jun  2 12:52:48 vpn pptpd[892]: CTRL: remote address = 192.168.30.50
Jun  2 12:52:48 vpn pptpd[892]: CTRL: pppd options file = /etc/ppp/pptpd-options
Jun  2 12:52:48 vpn pptpd[892]: CTRL: Client 192.168.28.154 control connection started
Jun  2 12:52:48 vpn pptpd[892]: CTRL: Received PPTP Control Message (type: 1)
Jun  2 12:52:48 vpn pptpd[892]: CTRL: Made a START CTRL CONN RPLY packet
Jun  2 12:52:48 vpn pptpd[892]: CTRL: I wrote 156 bytes to the client.
Jun  2 12:52:48 vpn pptpd[892]: CTRL: Sent packet to client
Jun  2 12:52:48 vpn pptpd[892]: CTRL: Received PPTP Control Message (type: 7)
Jun  2 12:52:48 vpn pptpd[892]: CTRL: Set parameters to 100000000 maxbps, 64 window size
Jun  2 12:52:48 vpn pptpd[892]: CTRL: Made a OUT CALL RPLY packet
Jun  2 12:52:48 vpn pptpd[892]: CTRL: Starting call (launching pppd, opening GRE)
Jun  2 12:52:48 vpn pptpd[892]: CTRL: pty_fd = 6
Jun  2 12:52:48 vpn pptpd[892]: CTRL: tty_fd = 7
Jun  2 12:52:48 vpn pptpd[892]: CTRL: I wrote 32 bytes to the client.
Jun  2 12:52:48 vpn pptpd[892]: CTRL: Sent packet to client
Jun  2 12:52:48 vpn pptpd[893]: CTRL (PPPD Launcher): program binary = /usr/sbin/pppd
Jun  2 12:52:48 vpn pptpd[893]: CTRL (PPPD Launcher): local address = 192.168.30.91
Jun  2 12:52:48 vpn pptpd[893]: CTRL (PPPD Launcher): remote address = 192.168.30.50
Jun  2 12:52:48 vpn pppd[893]: Plugin /usr/lib/pptpd/pptpd-logwtmp.so loaded.
Jun  2 12:52:48 vpn pppd[893]: pppd 2.4.5 started by root, uid 0
Jun  2 12:52:48 vpn pppd[893]: Using interface ppp0
Jun  2 12:52:48 vpn pppd[893]: Connect: ppp0 <--> /dev/pts/1
Jun  2 12:52:48 vpn pptpd[892]: GRE: Bad checksum from pppd.
Jun  2 12:52:48 vpn pptpd[892]: CTRL: Received PPTP Control Message (type: 15)
Jun  2 12:52:48 vpn pptpd[892]: CTRL: Got a SET LINK INFO packet with standard ACCMs
Jun  2 12:52:48 vpn pptpd[892]: GRE: accepting packet #1
Jun  2 12:52:51 vpn pptpd[892]: GRE: accepting packet #2
Jun  2 12:52:54 vpn pptpd[892]: GRE: accepting packet #3
Jun  2 12:52:57 vpn pptpd[892]: GRE: accepting packet #4
Jun  2 12:53:00 vpn pptpd[892]: GRE: accepting packet #5
Jun  2 12:53:03 vpn pptpd[892]: GRE: accepting packet #6
Jun  2 12:53:06 vpn pptpd[892]: GRE: accepting packet #7
Jun  2 12:53:09 vpn pptpd[892]: GRE: accepting packet #8
Jun  2 12:53:12 vpn pptpd[892]: GRE: accepting packet #9
Jun  2 12:53:15 vpn pptpd[892]: GRE: accepting packet #10
Jun  2 12:53:18 vpn pppd[893]: LCP: timeout sending Config-Requests
Jun  2 12:53:18 vpn pptpd[892]: GRE: read(fd=6,buffer=610d20,len=8196) from PTY failed: status = -1 error = Input/output error, usually caused by unexpected termination of pppd, check option syntax and pppd logs
Jun  2 12:53:18 vpn pptpd[892]: CTRL: PTY read or GRE write failed (pty,gre)=(6,7)
Jun  2 12:53:18 vpn pptpd[892]: CTRL: Reaping child PPP[893]
Jun  2 12:53:18 vpn pptpd[892]: CTRL: Client 192.168.28.154 control connection finished
Jun  2 12:53:18 vpn pptpd[892]: CTRL: Exiting now
Jun  2 12:53:18 vpn pptpd[891]: MGR: Reaped child 892

Here is my pptpd-options file:

refuse-pap
refuse-chap
refuse-mschap
require-mschap-v2
require-mppe-128
proxyarp
nodefaultroute
lock
nobsdcomp
noipx
#mtu 1490
#mru 1490

When I watch the activity of the ppp0 interface which comes upon the connection, I see no activity at all.

Please advise. Thanks !

share|improve this question
    
check option syntax and pppd logs. Could you provide us pppd logs ? –  petrus Jun 2 '11 at 9:12
    
You may want to add debug to your pptpd-options file. –  Turbo J Jun 5 '11 at 3:27

1 Answer 1

up vote 3 down vote accepted

This could be a firewall problem. Check that you are allowing the correct traffic into your VPN Server, specifically you need to permit TCP 1723 and Protocol 47 (GRE) before PPTP will work correctly. The problem you see in your log can be caused by GRE not being correctly relayed from your firewall.

You might also need to add mppe-stateful to your pptpd-options file to allow windows hosts. Depending on how many intermediate NAT routers your connections may pass through you will need to reduce the mru and mtu settings.

share|improve this answer
    
It might also be a firewalling problem on the client's local network - try connecting from somewhere else if you can. –  poolie Sep 18 '12 at 0:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.