Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I set up virtual ftp so I could log in using virtual|mybackup.com using mybackup.com IUSER permissions.

Now it stopped working :-( The authentication is OK, but the authorization using user mybackup.com is not working on f:\backup but it is working on the original location c:\inetpub\vhosts\mybackup.com\

I have double checked, the permissions are THE SAME on both locations.

What could be the reason? Can iis have any restriction that dissalow ftp to the location outside of the inetpub?

Is there any other way to make user mybackup.com ftp to somewhere else, not the default user location? I have only one IP address so I can not set up more than one FTP's, so I was doing it using virtual. But it stopped working and I can not find the fault, why it says folder is not existing, if it is :-/

share|improve this question

2 Answers 2

You have enabled the option "Isolation mode" on FTP to create home folders for each user (or indiviual sites). Is this a must? because if so you can't change it. It defaults to that location. If you turn this off you can set this location and it goes there for all users. So if you are only using the one user turn it off and it will work. If you can't do this then you are out of luck.

Read the link Trent sent and it shows you how to turn off isolation mode.

Also note this from the article:

• For anonymous users, the home directory is LocalUser\Public under the FTP root directory.

• For local users, the home directory is LocalUser\UserName under the FTP root directory.

• For users that log on with Domain\UserName, the home directory is Domain\UserName under the FTP root directory.

The user home directory must be created before the user logs on. If the directory does not exist when the user attempts to connect, the connection is denied.

share|improve this answer

The way I solved this was with ActiveDirectory, not sure if you are using that but you can set an msiisFTP-Root and msiisFTP-Base AD property

http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/b63de8ef-e3c5-456d-a8ca-7af4198819d4.mspx?mfr=true

share|improve this answer
    
I think Active directory does not work with my Windows 2008 WEB edition. –  Jerry2 Jun 2 '11 at 11:10
    
Well, it can be a member of an active directory domain, but it couldn't be a standalone active directory server, no. –  Trent Lloyd Jun 3 '11 at 1:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.