Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We are running a CentOS 5.6 system, and want to install php53 with php-mcrypt.

However, this introduces a dependency conflict between php-common & php53-common. Does anyone have a good workaround for this problem?

host # yum install php-mcrypt
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * epel:
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php-mcrypt.x86_64 0:5.1.6-15.el5.centos.1 set to be updated
--> Processing Dependency: php-api = 20041225 for package: php-mcrypt
--> Processing Dependency: php >= 5.1.6 for package: php-mcrypt
--> Running transaction check
---> Package php.x86_64 0:5.1.6-27.el5_5.3 set to be updated
--> Processing Dependency: php-cli = 5.1.6-27.el5_5.3 for package: php
---> Package php-common.x86_64 0:5.1.6-27.el5_5.3 set to be updated
--> Running transaction check
---> Package php-cli.x86_64 0:5.1.6-27.el5_5.3 set to be updated
--> Processing Conflict: php53-common conflicts php-common
--> Finished Dependency Resolution
php53-common-5.3.3-1.el5_6.1.x86_64 from installed has depsolving problems
  --> php53-common conflicts with php-common
Error: php53-common conflicts with php-common
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

This is apparently a known problem (See php-devel, Bug 700179 and Bug 695708) and this post at the CentOS forums, but there is no official fix yet.

share|improve this question

Work-around: Use iuscommunity ( ) and install php53u-mcrypt.

In general, you will install packages with named of the form php53u-foo.

share|improve this answer
We're going with this workaround for now, but I am hoping to use the RHEL/CentOS packages for simplicity. I am hoping that someone else has come up with a clean solution for this, because this problem affects many php-* packages. – Stefan Lasiewski Jun 2 '11 at 23:41

IT is very late but as I came via a search other people might find the following helpful. Had the same trouble described above. Problem was that I tried to run

yum install php-gd

this threw the error above

yum install php53-gd 

did not as this belongs to installed php package's installed.

you could find all available packages via

yum search php53


share|improve this answer
also works for php53-xml thanks – jermdemo Mar 10 '15 at 2:20

safer to uninstall php and all php-xxx package before installing php53

share|improve this answer
Are you saying that if I install php-xxx first, before installing php53 (this is the reverse of how we did it at first), then the conflict will be avoided? – Stefan Lasiewski Jun 7 '11 at 19:17
Actually I am using IUS too, sorry for not mentioning earlier. Anyway, I cleaned up all installed php-xxx package before installing any php53u-xxx and it worked just fined. – lenzai Jun 7 '11 at 19:28

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.