Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We are running a CentOS 5.6 system, and want to install php53 with php-mcrypt.

However, this introduces a dependency conflict between php-common & php53-common. Does anyone have a good workaround for this problem?

host # yum install php-mcrypt
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * epel: linux.mirrors.es.net
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php-mcrypt.x86_64 0:5.1.6-15.el5.centos.1 set to be updated
--> Processing Dependency: php-api = 20041225 for package: php-mcrypt
--> Processing Dependency: php >= 5.1.6 for package: php-mcrypt
--> Running transaction check
---> Package php.x86_64 0:5.1.6-27.el5_5.3 set to be updated
--> Processing Dependency: php-cli = 5.1.6-27.el5_5.3 for package: php
---> Package php-common.x86_64 0:5.1.6-27.el5_5.3 set to be updated
--> Running transaction check
---> Package php-cli.x86_64 0:5.1.6-27.el5_5.3 set to be updated
--> Processing Conflict: php53-common conflicts php-common
--> Finished Dependency Resolution
php53-common-5.3.3-1.el5_6.1.x86_64 from installed has depsolving problems
  --> php53-common conflicts with php-common
Error: php53-common conflicts with php-common
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

This is apparently a known problem (See php-devel, Bug 700179 and Bug 695708) and this post at the CentOS forums, but there is no official fix yet.

share|improve this question

6 Answers 6

I had the same problem I used Kloxo command service to execute shell command after that I used WinSCP commad
but in both of them I have same error ( conflict with php-common)

after all I tried to use putty command windows and saw that after all unistalling old version and install new version there is a confirmation question that I could not answer it in 2 Kloxo and WinSCp

after I confirmed the unistalling old version I could install PHP53 with no conflict all the command is this for uninstall the old version

yum erase php php-pear php-mysql php-cli php-common

and confirm with y

yum install php53

and confirm with y

yum install php53-mysql
share|improve this answer

I got the same issue..

"php53-common conflicts with php-common"

then i reinstall the PHP with yum by giving

yum reinstall php*

now it's working fine.

share|improve this answer
1  
Tried this; didn't help. –  Teemu Leisti Oct 6 '12 at 22:54

IT is very late but as I came via a search other people might find the following helpful. Had the same trouble described above. Problem was that I tried to run

yum install php-gd

this threw the error above

yum install php53-gd 

did not as this belongs to installed php package's installed.

you could find all available packages via

yum search php53

cheers!

share|improve this answer

I have had great luck with this link:

http://pjwelsh.blogspot.com/2010/12/linux-rhelcentos-55-php-53-upgrade-made.html

Note: The other is a name change for php53 to php53u to get past an naming issue with RHEL/CENTOS 5.6.

So for CentOS 5.6, dont use php53, use php53u.

This "yum search php53" will show the available packages.

share|improve this answer

safer to uninstall php and all php-xxx package before installing php53

share|improve this answer
    
Are you saying that if I install php-xxx first, before installing php53 (this is the reverse of how we did it at first), then the conflict will be avoided? –  Stefan Lasiewski Jun 7 '11 at 19:17
    
Actually I am using IUS too, sorry for not mentioning earlier. Anyway, I cleaned up all installed php-xxx package before installing any php53u-xxx and it worked just fined. –  lenzai Jun 7 '11 at 19:28

Work-around: Use iuscommunity ( http://iuscommunity.org/ ) and install php53u-mcrypt.

In general, you will install packages with named of the form php53u-foo.

share|improve this answer
1  
We're going with this workaround for now, but I am hoping to use the RHEL/CentOS packages for simplicity. I am hoping that someone else has come up with a clean solution for this, because this problem affects many php-* packages. –  Stefan Lasiewski Jun 2 '11 at 23:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.