Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have xrvt running with the screen command, but it flickers every time I press, say the right arrow key. (It flickers white). Any ideas as to why?

Ps. Gnome terminal is hard to set up with 6x13 condensed bitmap fonts...

share|improve this question

2 Answers 2

up vote 4 down vote accepted

This is a default screen behaviour (it flashes instead of beeping your pc-speaker).

Try this while running screen: setenv vbell off

Does the problem go away?

share|improve this answer
    
C-a C-g at least works. Where do I make it permanent? Thanks! –  Dervin Thunk Jun 17 '09 at 22:03
    
Screen's default is "visual bell", not "audible bell". That might help with any searching. –  David Pashley Jun 17 '09 at 22:04
1  
You can enter settings into ~/.screenrc, check the screen manpage for more info (man screen) –  pauska Jun 17 '09 at 22:06

Edit /etc/screenrc (and also inputrc if you wish) and turn bell and vbell to be off. This works for me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.