Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Using Ubuntu Server I have a test-server that sends out mails in PHP scripts. Other than that, it does not do anything with mail. However, I have a bunch of "pop3-login" processes going on. It appears to be somebody/something is trying to login to the pop3 mailboxes. But no POP3 mailboxes are (or should be) working. Is there an easy way to turn off pop3 (or imap) logins for Dovecot? I only need outgoing mails in PHP...

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

If you don't use imap or pop3, then remove dovecot:

sudo aptitude remove dovecot dovecot-pop3d dovecot-imapd

Dovecot has nothing to do with your outgoing mail, you're probably using postfix, exim, or some other MTA for that.

If you want to use IMAP but not POP3, then just remove the dovecot-pop3d backage. If you want POP3 but not IMAP, just remove dovecot-imapd.

share|improve this answer
add comment

I set the option login_max_processes_count = 0 in dovecot.conf. So far it's working.

share|improve this answer
2  
-1 This is a really bad idea. Dovecot is not SMTP software and should not be running or installed if you don't need it. If there are any security vulnerabilities in the software, you're leaving the door wide open for absolutely no reason. –  Chris S Jul 27 '12 at 13:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.