Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm running php with curl support on a mac. cURL in php works fine(ish) but I noticed an oddity reported by phpinfo(). It states that curl support is 7.19.7

But using the otool command, I get this:

# otool -L `which php`
   /usr/local/bin/php:
        ...
        /usr/lib/libcurl.4.dylib (compatibility version 6.0.0, current version 6.1.0)
        ...

I was wondering what is the relationship between libcurl's 'current version 6.1.0' and php curl's 'curl support 7.19.7'?

Basically just making sure I don't have a version mismatch, because I'm experiencing some PHP DNS issues that I'm trying to debug.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.