Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

How do I upgrade from PHP 5.2.0 to anything > PHP 5.2.3 on Debian Etch? Do I need to use backports (not quite sure how to do it)? I tried dotdeb.org, but they don't support Etch. I'd like to upgrade to the latest 5.3.*, but I will be content with anything > 5.2.3.

My current sources.list:

deb http://archive.debian.org/debian/ etch main

Many thanks for any insight.

EDIT:

For reference, this serverfault post was no help because of the dotdeb.org note I made above.

share|improve this question
1  
It is time to upgrade. The is no longer any official security updates for etch. –  Zoredache Jun 4 '11 at 18:18

1 Answer 1

up vote 2 down vote accepted

Debian Backports (for Etch) only has 5.2.0 anyway:

# apt-cache policy php5
php5:
  Installed: (none)
  Candidate: 5.3.6-11
  Version table:
     5.3.6-11 0
        800 http://mirrors.kernel.org/debian/ sid/main amd64 Packages
     5.2.0+dfsg-8+etch16 0
        500 http://archive.debian.org/debian/ etch/main amd64 Packages

I checked this by first adding the Debian Backports source to my list:

deb http://archive.debian.org/debian-backports/ etch-backports main

You should probably upgrade to Lenny or try to install Lenny's package, perhaps using APT pinning.

share|improve this answer
    
Since upgrading isn't an option, I'll give APT pinning a try. Never heard of it, but after reading the page, it looks like it's what I'm after. –  Jeff Jun 4 '11 at 13:08
    
BTW, +1 for the APT pinning link. ;) –  Jeff Jun 4 '11 at 13:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.