Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am new to Heroku. I tried to use the command heroku to get some inforamtion of my apps.

I can use heroku list to get the list. But when I use heroku info, it returns

App not found

What's the problem? How can I fix this error?

Thank you in advance.

share|improve this question

migrated from Jun 6 '11 at 13:56

This question came from our site for professional and enthusiast programmers.

You need to either run

heroku info --app name-of-app

or run

heroku info

from the base directory of one of your heroku-hosted applications.

share|improve this answer
Thanks buddy. I run both commands in the base directory, but same error pop up.... any idea? – Victor Lam Jan 4 '11 at 16:15
What does the command 'git remote show heroku' return? does the remote git match that of one fo the apps in the heroku info result? – Steve Wilhelm Jan 4 '11 at 21:05
oops... i got Permission denied (publickey). fatal: The remote end hung up unexpectedly..... how come?! I don't understand... I can deploy the app to heroku with no problem..... – Victor Lam Jan 5 '11 at 17:38
have you tried generating a new public key? – corroded May 30 '11 at 16:51

there's two sets of credentials in use here. Git uses your SSH key and heroku CLI will use your heroku credentials

From the command line do

heroku auth:login

and enter your heroku credentials and you should be back up and running

share|improve this answer
This worked for me! I don't know why that became an issue all of a sudden. I think they need a better error message. – Bruno Bronosky Feb 3 '15 at 19:59
Just damn. I spoke too soon. Now heroku info works, but heroku logs -tail still gives me ` ! App not found.` – Bruno Bronosky Feb 3 '15 at 20:00

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.