Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have Windows Server 2003 with Active Directory. When I try to create a user, then add it to the administors group the user still has the same privileges. In other words, when I try to give administrative privileges it doesn't work, the user still retains the same permissions.

share|improve this question
    
Rights (privileges) and permissions are 2 different things. Can you tell us what you're trying to have this user do or access so we can determine if this is a rights issue or a permissions issue. –  joeqwerty Jun 7 '11 at 11:18
    
What doyou mean by administrative rights? What are you trying to allow them to do? –  uSlackr Jun 7 '11 at 11:27
    
for example I have user1 and I want this user1 be administrator so right click of user1 then properties then member at the point I added administrators I think this is the right way to promote to give administrative permission and what is difference between privileges and permissions? and why when I have copied old administrator user it works? thanks –  Codey Jun 7 '11 at 11:51
    
The difference between rights and permissions is basically this: rights determine what you can do (reset passwords) while permissions determine what you can access (files and folders). –  joeqwerty Jun 7 '11 at 12:32
1  
Are you adding the user to "Administrators" or "Domain Admins"? These do different things. –  Handyman5 Jun 7 '11 at 22:38

3 Answers 3

Is the user a member of any other groups with more restrictive rights against the same objects? If so, the most restrictive rights will take affect.

share|improve this answer
    
There is no group restrictive rights against the same objects the user member in domain users and administrators and I cant delete domain users message appeared the primary group can not be removed.select another group as primary if you want to remove this one so where is the problem? –  Codey Jun 7 '11 at 10:05

The users need to log off and back on again before the changes take effect.

share|improve this answer
    
I already tried but it didn't work, another ideas please? –  Codey Jun 7 '11 at 10:06

Have you tried copying another account that has the permissions you wish the new user to have. If that works then as user48838 suggested confirm the account isn't a member of an restricted group or an member of a group that is denied access via NTFS.

share|improve this answer
    
It works I copied administrator user with another name. but how can I know if this user denied access via NTFS or how can I permit access via NTFS? –  Codey Jun 7 '11 at 10:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.