Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When I receive an email on Google from my domain ("mail.gramma.ro") I see this in the headers:

Received-SPF: softfail (google.com: best guess record for domain of transitioning cristi@gramma.ro does not designate 213.133.103.5 as permitted sender) client-ip=213.133.103.5;

My SPF is defined as:

v=spf1 a mx ~all

Can you please tell me why Google sees it with softfail status?

share|improve this question
add comment

3 Answers

up vote 7 down vote accepted

Looks valid. Try specifying the IP address though as that takes out a level of possible failure.

v=spf1 a mx ip4:213.133.103.5 ~all

EDIT

I'll clarify. I'm NOT saying that this should be a permanent solution. This is enough to get things working (and email flowing) until the real problem can be found.

share|improve this answer
    
Thanks, this made it to have pass status –  user22817 Jun 7 '11 at 20:15
    
Good suggestion... but it should have worked anyway. –  Massimo Jun 7 '11 at 20:17
2  
This is only serving to obfuscate the real problem, which appears to be a problem with the name server records for gramma.ro. –  joeqwerty Jun 7 '11 at 20:17
    
I should clarify my comment: your answer solves the problem but my concern is there's an underlying issue that's probably going to manifest itself in other ways. That was the intention of my comment to your answer. Hopefully no offense was taken. –  joeqwerty Jun 7 '11 at 23:19
    
@joe - Absolutely no offense taken. It's a very valid concern you have. –  Jason Berg Jun 7 '11 at 23:25
add comment

Based on your A and MX records (as reported at www.dnsstuff.com) and based on the SPF record, I can't tell why it's failing but I can tell you that ~all tells Google to treat it as a soft failure.

EDIT

It's probably a DNS lookup problem. The name servers for your domain as listed by your name servers are:

gramma.ro

ns.gramma.ro

But the name servers listed at the parent servers are:

ns.gramma.ro

This is probably causing some name resolution problems for you.

share|improve this answer
    
Thanks..actually I have a warning:"The DNS server computer currently does not have a DNS domain name. Its DNS name is a single-label host name with no domain (for example: "host" rather than "host.microsoft.com"). You might have forgotten to configure a primary DNS domain for the server computer. "...Is this the problem you also noticed? Sorry I am a programmer not a server admin, that's why I am novice in this area.... –  user22817 Jun 7 '11 at 20:31
    
My computer name is: OWNEROR-D25M4R5 member of Workgroup: WORKGROUP. Should I select to be Member of Domain: and enter gramma.ro? Will I be able to log in back after that...? –  user22817 Jun 7 '11 at 20:38
    
In response to your first question to my answer: Yes, that's what I found in the report from www.dnsstuff.com. The parent servers have ns.gamma.ro listed as the name server but ns.gamma.ro has ns.gamma.ro and gamma.ro listed as name servers. I'm not sure if this could cause the problem or not, but the problem appears to be DNS related to me so I would certainly fix it before moving on. –  joeqwerty Jun 7 '11 at 20:41
    
Yeah, So in my Windows Server config I've defined: gramma.ro and ns.gramma.ro as NS. Should I remove ns.gramma.ro from here or add gramma.ro to my provider where I register that ns.gramma.ro also? –  user22817 Jun 7 '11 at 20:53
1  
Honestly I would get rid of gramma.ro on your DNS server and set up another name server, such as ns2.gramma.ro and register this new server on your DNS server(s) and at the registrar. –  joeqwerty Jun 7 '11 at 20:56
add comment

Your record looks to be set correctly (MX resolves back to mail.gramma.ro which resolves to 213.133.103.5), but Google is using "best guess" instead of the actual specified record.

It's likely that you sent this test message too soon after setting up the record, and the Google servers didn't get the record at all when this check occurred. Try sending a new test message.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.