Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I want to upgrade my postgres8.3 to 8.4 for single domain. Don't affect other domain. How to manage it. Is it possible?

share|improve this question
    
Linux distibution –  user586445 Jun 8 '11 at 6:59
    
Why not run just 8.4 instead of 8.3 and 8.4? –  sciurus Jun 8 '11 at 7:16
add comment

migrated from stackoverflow.com Jun 8 '11 at 7:06

This question came from our site for professional and enthusiast programmers.

2 Answers

It is possible... but not easy in all cases. In most distributions, it will be hard to install both of them using the package manager (because they will both provide the same capabilities). Supposing 8.3 has been installed using the package manager, you have to install 8.4 manually (using directly the archives you'll find on the official site).

The important step I can directly see :

  • Install it in a logical place - respect the Unix architecture as far as possible.
  • You have to create a dedicated script to declare it as a service. You certainly can use the one for 8.3 as a base. It will be in /etc/init.d, and you'll have to create the good links to be sure the service automatically starts on boot
  • You have to be sure there are not any conflict between the thwo DB configurations. Particularly, be sure you don't listen on the same port. And be sure to declare the good port in the good configuration...
  • You have to be sure that you don't erase the former binaries, those in /bin (or /usr/bin, or wherever they arae) that will let you manage your database. I don't know how freely you can use them with two databases installed.

Hope it will help you.

share|improve this answer
    
ca you give any official iste link? –  user586445 Jun 8 '11 at 10:15
add comment

Assuming you're compiling from source, no problem. Set an appropriate prefix and data dir during the configure step, and you're good to go. If you're relying on your system's package manager, that's probably not going to work. If you're doing this as a migration process from 8.3 to 8.4, it'll be cleaner to take a reliable backup and then upgrade in place; if that's what you're doing, consider the forthcoming 9.x branch of postgres.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.