Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just did a yum install of php on amazon linux beta. (it's similar to centos, jfyi)

php -v reveals its php 5.3.6. awesome so. Now I am trying to figure out if I can package install the php-fpm.

cant find anything specific on FPM. doc says its included but it seems it might need to be compiled. I don't see a yum install php-fpm to make my life easier. :)

so please do guide me on this if you know how. alternatively if we need to compile I would appreciate the complete configure param to help me a bit. I don't want to miss anything essential in compile time.

thank you in advance , need sleep

share|improve this question
up vote 1 down vote accepted

Alright I eventually figured out that I need to compile. Loaded all the params after much googling and copying the phpinfo for the existing install.

I got the fpm compiled and installed then used the yum for any missing pecl packages since its the same version it worked fine.

one issue remained is the init script for fpm in the source does not really work. it picks up the param and env paths etc all ok but something is not right so it just fails to work.

usually a pecl install is available in yum. But not always.

share|improve this answer
thanks for that pointer. i thought i would allow for some more feedback on my answer. and now new answer has shown up too. If other answers evolve to be better than mine I would mark it so. or so i hope... so good to wait, no? – Vangel Jun 17 '11 at 4:07

Once compiled you need to check the user/group defined within the configuration file as well as modifying some options like the dynamic workers or the php options. The later caused me some headache as i had forgotten to remove them. Did you check the fpm error log ? What errors are reported ?

share|improve this answer
i got problems with the workers as well. I had to edit the php-fpm.conf files as apparently default values dont work correctly (as of 5.3.6) so while it works now the init script does not work, it claims to not find the pid file... then attempts to start and shows fail. Even though php-fpm process is started. interesting thing you mentioned regarding workers. would you care to share an example of these options specified during compile? noe more problem: despite having specified--disable-pdo --disable-phar etc it continues to compile and add it. same thing for --without-sqlite, has no effect – Vangel Jun 17 '11 at 4:04
You must check both the php-fpm conf file as well as the php.ini used by fpm. When compiling did you specify the path to the php.ini file ? – olefebvre Jun 17 '11 at 14:04
yes what you said I have already done. As I mentioned in my own answer I got the FPM working by manually editing the conf files. However the Init script does not work properly. Would you happen to have the parameters you used to compile? I could try it out on an instance and work from there. am using on CentOS-like os and I can modify the params to suit my setup, thanks – Vangel Jun 19 '11 at 3:47

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.