Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am hosting SVN on apache - ubuntu server. I thought all I needed to do to add access was edit the /etc/svn/access file with users or SVN.

But whenever I try to access the SVN after restarting apache, I still get the forbidden message.

Any help is appreciated.

This is part of my /etc/svn/access

[repo:/]
user1 = rw
user2 =rw

also, this in my apache configs

  # Our access control policy
  AuthzSVNAccessFile /etc/svn/access
  Require valid-user
share|improve this question
1  
Please, show a part of apache config file, relevant to SVN configuration. Do you have authentication enabled there? –  HUB Jun 8 '11 at 13:56
    
updated the main post –  kirbyfree Jun 8 '11 at 13:58
1  
I'm not shure, but may be it is worth adding "AuthType Basic" and "AuthUserFile /etc/apache2/passwd/svn_users.passwd" before "Require valid-user"? Then apache would ask for a username and password... –  HUB Jun 8 '11 at 14:30
    
And of course, "SVNParentPath /data/svn" or "SVNPath /data/svn" directive also needed. –  HUB Jun 8 '11 at 14:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.