Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to activate the Ftpservice on my Root Server, I have OpenSuse installed, and I'm using the xinetd method.

I added this to my xineted.conf:

 service ftp
    {
        flags       = REUSE
        socket_type = stream
        protocol    = tcp
        wait        = no
        user    = root
        server      = /usr/sbin/in.proftpd
        disable = no

    }

I'm not sure about this server = /usr/sbin/in.proftpd. I added the code directly in the xinetd.config and not in a separate file.

and to my proftpd.conf as the documentation of profdtp ( was already set):

ServerType inetd

Then I restarted the xineted service and no errors to see, but proftpd is still not starting/launching. I searched a lot on google, but everywhere they say to do what i did above, nothing more. Did I miss something ?

share|improve this question

2 Answers 2

up vote 0 down vote accepted

How are you checking to see if the FTP service is running? The process table won't contain any running proftpd's because you're running it through xinetd instead of as a stand-alone daemon: when someone connects to port 21, xinetd answers and then invokes proftpd to handle the connection. What happens if you telnet to TCP port 21 of the server?

After that, if the connection fails, verify that /usr/sbin/in.proftpd exists. If not you might try changing the xinetd configuration to use /usr/sbin/proftpd instead.

share|improve this answer
    
well i was trying to make a ftp connection ( the users were setted in plesk panel) ,, and filezilla doesnt get a responde from the server.. but u r right, i totally forgot about that there is no process running from proftpd after restarting xinetd .. But: /usr/sbin/proftpd worked for me thanks! –  a_ak Jun 8 '11 at 19:53

xinetd sends log messages to syslog. Try looking in /var/log/messages to see if there are any diagnostic messages that might point you to the problem.

Did you try setting up xinetd from YaST->Network Services?

Is there a particular reason you have to use Proftpd? There are packages for vsftpd and pure-ftpd that might be easier to configure using YaST.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.