Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I was trying to use the mod_proxy_balance module of apache to setup a loadbalancer for 2 webservers in the background. I thought I successfully did. Here's what happened:

  1. My proxy is in I enabled to be redirected to 2 webservers and

  2. Now if I enter in my address bar, I am able to reach those webservers. But I cannot access any page beyond it. eg If I enter . It says Internal server error. It is misconfigured. If I enter , I am able to access it.

I followed this tutorial to setup the mod_proxy_balance.

Can you please let me know what exactly I am doing wrong?

share|improve this question
Config files or it didn't happen. –  Janne Pikkarainen Jun 9 '11 at 6:37
In the client side, My program gives Connection Time out. The load balancer error logs give : do_ypcall: clnt_call: RPC: unable to send;errno = Operation not permitted –  sethu Jun 9 '11 at 15:57
Can you post the relevant portion of your httpd.conf configuration that contains your proxy directives? –  mahnsc Jun 11 '11 at 21:23
<IfModule mod_proxy_balancer.c> <Proxy balancer://> BalancerMember loadfactor=1 BalancerMember loadfactor=1 </Proxy> <Location /> ProxyPass balancer:// </Location> </IfModule> –  sethu Aug 19 '11 at 3:41

1 Answer 1

up vote 1 down vote accepted

Problem solved! I just disabled the firewall at the proxy !!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.