Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The defaults in the sample sip.conf under Asterisk1.8 contain udpbindaddr= and tcpbindaddr= I want to bind the incoming [foo] extension to udp:, the outgoing [foo] to tcp:, the incoming [bar] to tcp:, and the outgoing [bar] to udp:

The topology as follows:

Softphone( [foo]) udp-> asteriskserver_0( tcp-> another server( tcp-> asteriskserver_0( udp-> hardphone( [bar]).

My original question was 'how to set the {udp,tcp}addr= variable to handle more than one IPs', but the more general question is how to configure the sip.conf and the extensions.conf?

share|improve this question
Why don't you simply enable routing? Surely that would be less difficult since you're using exclusively private addresses. – geocar Jun 9 '11 at 9:18
How can I set it explicitely? Or is it set internally? – tarkaköpönyeges csecsfogdosó Jun 9 '11 at 9:19
Add a new question. Draw your network and ask how to set up routing. It's really off-topic (has nothing to do with asterisk). – geocar Jun 9 '11 at 9:21
I'm afraid I can't understand you. The network is working, capable to transfer UDP and TCP, firewalls are out of consideration. The only problem is solely with Asterisk. – tarkaköpönyeges csecsfogdosó Jun 9 '11 at 9:43
It shouldn't matter if asterisk binds to if hardphone can connect to – geocar Jun 9 '11 at 21:10

Asterisk can bind to single ip or to all ip same port. No other options.

If you expect different ports on different interfaces, you have setup more advanced(and much more complex) sip proxy, like opensips/kamailio.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.